List:General Discussion« Previous MessageNext Message »
From:Michael Widenius Date:October 7 1999 10:20pm
Subject:Phantom column
View as plain text  
>>>>> "Sean" == Sean Leach <sal@stripped> writes:

>> Description:
Sean> When I tried to do an insert into a table, it said the column "billCounty" wasn't
> found, though it had been working prefectly all along with the same code/table.  When a
> did a "desc" on the table, the column was there.  When I did a "SELECT billCounty FROM
> ..." it said column not found.  Then I tried to just add the column to the table to see
> what would happen, it said "Can't add column, already exists".  So to fix the problem, I
> had to drop the column, and re-add it.

>> How-To-Repeat:
Sean> Not sure how to repeat, it only happened to this one table in this one database. 
> I have about 10 databases with the same schema.
>> Fix:
Sean> Had to drop/add the column.  This would have sucked if there was useful info in
> theat column.  The column even showed up in a mysqldump of the table.


Next time this happens, please include a cut and past of the whole
thing!   As I have never heard about the above problem before, I can only
conclude that you must have misspelled it...


Phantom columnSean Leach7 Oct
  • Phantom columnMichael Widenius8 Oct