List:General Discussion« Previous MessageNext Message »
From:Randy_Chrismon/FDS Date:September 14 2003 3:02am
Subject:MySQL Won't Shut Down
View as plain text  
After installing MySQL 4.1 on a Win2K machine, I tried to run the 
mysql_fix_privilege_tables.sql script. I got the duplicate column name 
errors which the documentation says I can safely ignore. However, I also 
got this error:

ERROR 1064 at line 67: You have an error in your SQL syntax.  Check the 
manual that corresponds to your MySQL server version for the right syntax 
to use near 'func ADD type enum ('function','aggregate') NOT NULL' at line 

Documentation didn't say nuthin' about no 1064 error. (Wonder if it's 
related to William the Conqueror?) Also, on a couple of occasions, I've 
tried to shut the MySQL process down, either from the gui or using "net 
stop mysql" and I get error messages that the server is not responding to 
the shutdown message, a time out or some other error. I have to re-boot to 
shutdown the MySQL server process (I have the process set to start 
manually -- usually using "net start mysql." This is just a 
test/develoment environment. The latest error message was: 

The service could not be controlled in its present state.

More help is available by typing NET HELPMSG 2189.

Although, in this case, this came after I aborted (ctl-C) net stop mysql 
and it filled up half the screen with dots while waiting for the shutdown. 
Interestingly, in most (all?) cases, the mysql.err log says MySQL shut 
down successfully even though it still shows as a process in the Win2K 
Task List, and can't be restarted without a reboot. 

What's going on here?

MySQL Won't Shut DownRandy_Chrismon/FDS14 Sep