List:General Discussion« Previous MessageNext Message »
From:Pierre-Luc Soucy Date:August 7 2003 12:59am
Subject:Re: Problem with merge tables in 4.1
View as plain text  
Hi Dan,

Ooops, this makes a lot of sense - it works now.

Thanks for letting me know about the perror utility, it should help 
greatly to identify problems in the future.



Dan Nelson wrote:

>In the last episode (Aug 06), Pierre-Luc Soucy said:
>>I was working on some merge tables this morning and it worked fine,
>>but after a few unsuccessful table creation requests (I was making
>>some tests), I could not alter or select from a table for the
>>following reason:
>>mysql> create table test_table (country CHAR(2) NOT NULL) TYPE=MERGE
> UNION=(countries);
>>Query OK, 0 rows affected (0.00 sec)
>>mysql> select * from test_table;
>>ERROR 1016: Can't open file: 'test_table.MRG'. (errno: 143)
>$ perror 143
>Error code 143:  Unknown error: 143
>143 = Conflicting table definitions in sub-tables of MERGE table
>Does your countries table layout match that of test_table?

Problem with merge tables in 4.1Pierre-Luc Soucy6 Aug
  • Re: Problem with merge tables in 4.1Dan Nelson6 Aug
    • Re: Problem with merge tables in 4.1Pierre-Luc Soucy7 Aug