MySQL Lists are EOL. Please join:

List:General Discussion« Previous MessageNext Message »
From:Lenz Grimmer Date:March 19 2003 4:20pm
Subject:Re: Problem reinstalling MySQL on Mac OS X
View as plain text  
Hash: SHA1


thanks for reporting this. I assume, you used the MySQL package from

On Thu, 6 Mar 2003, Perry Arnold wrote:

> I installed the MySQL binary (4.0.11-gamma package) on my Mac OS X
> machine (version 10.2.4) and I couldn't get it to start up. When I run
> bin/mysqld_safe, I kept getting the error "Fatal error: Can't open
> privilege tables: Table '' doesn't exist" [note: I later
> figured out that I *think* I'm getting this error because my machine
> does not have a recognizable hostname (i.e. you can't look it up via
> normal DNS)].

Hmm, this case is currently not properly handled, indeed. Thanks for the
hint! mysql_install_db simply aborts, if the host name cannot be resolved,
but the error does not get fed back to the installer itself...

> After mucking around for quite a while without much success, I decided
> to start over and reinstall from scratch. So, I deleted my mysql
> directory and reinstalled from the Package. Now, when I try to run
> bin/mysqld_safe, I get the following error: "InnoDB:  Operating system
> error number 13 in a file operation." It looks like when you reinstall
> from the package, it skips the step where it changes file permissions of
> the data directory and its subdirectories.
> How-To-Repeat:
> On a fresh MacOS X 10.2.4 system, (1) install the 4.0.11-gamma package,
> (2) delete the mysql directories (the /usr/local/mysql link and
> /usr/local/mysql-standard-4.0.11-gamma-apple-darwin6.4-powerpc
> directory), (3) install the 4.0.11 package again, (4) run
> bin/mysqld_safe.
> Fix:
> Change the file permissions of the data directory and its
> subdirectories. Ideally, this would be fixed within the Package
> installer, but a release note or something would work as well.

This is interesting. Are you sure you removed all mysql directories in
/usr/local? The installation package includes a postinstall script, that
does the following:

if cd /usr/local/mysql ; then
        if [ ! -f data/mysql/db.frm ] ; then

        if [ -d data ] ; then
                chown -R mysql data
        exit $?

/usr/local/mysql is a symlink, pointing to the real installation directory
and is included in the package itself. So if you really removed all files,
the ownerships should have been set up correctly. Unfortunately it's very
hard to debug this problem, since the Package Installer does not offer any
logging functionality...

After looking through your mail again, I wonder how you tried to start
MySQL. Did you use "sudo mysqld_safe", as described in the docs? If you
try it as a "normal" user (omitting "sudo", the directory permissions and
ownerships indeed will give you a "permission denied" error message. This
is intentional!

- -- 
For technical support contracts, visit
   __  ___     ___ ____  __
  /  |/  /_ __/ __/ __ \/ /      Mr. Lenz Grimmer <lenz@stripped>
 / /|_/ / // /\ \/ /_/ / /__     MySQL AB, Production Engineer
/_/  /_/\_, /___/\___\_\___/     Hamburg, Germany
Version: GnuPG v1.2.2-rc1-SuSE (GNU/Linux)
Comment: For info see

Problem reinstalling MySQL on Mac OS XPerry Arnold6 Mar
  • Re: Problem reinstalling MySQL on Mac OS XLenz Grimmer19 Mar