List:General Discussion« Previous MessageNext Message »
From:Jeff Kilpatrick Date:March 13 2003 5:49pm
Subject:Replication [p]threads problem
View as plain text  

I upgraded three servers to 3.23.55 over the weekend configured them to
be peers in a daisy-chain setup.  It's worked well with one exception:

Our FreeBSD 4.6 server (built from the ports collection) crashed (this
morning; on day five of uptime) with the following in the log:

Fatal error '_pq_insert_tail: Already in priority queue' at line ? in
file /usr/src/lib/libc_r/uthread/uthread_priority_queue.c (errno = ?)

I tracked this down to
/usr/src/lib/libc_r/uthread/uthread_priority_queue.c and in the
MySQL distribution.

The crash left an irresponsive mysqld process running, which had to be
killed with SIGKILL.  Everything works fine again after a restart of the
server, followed by SLAVE STOP; and SLAVE START;

I ran through the binlog at the appropriate position (with mysqlbinlog)
and found nothing out of the ordinary running up to it.  It may also be
worth noting that the server daemons on the OSX box and Linux box had no
problems and kept chugging along.

I would doubt that it matters, but the master for this machine is
running MacOS Jaguar.


Jeff Kilpatrick <kilpatjr_at_lupusDoTomrfdOtouhscd0Tedu>
Oklahoma Medical Research Foundation

Replication [p]threads problemJeff Kilpatrick13 Mar
  • Re: Replication [p]threads problemDan Nelson13 Mar