List:General Discussion« Previous MessageNext Message »
From:Christian Mack Date:September 13 1999 6:07pm
Subject:Re: Bug in MySQL concerning multiple ethernet devices (probably)
View as plain text  
Thomas van Gulick wrote:
> I have been buggering the list with my segfault problems for some time, but
> I believe I have found the real problem now. They are easily reproducable on
> my system. Here is my setup:
> utumno, gateway with two ethernet devices, (frontend) and
> (backend). The host itself is called 'utumno'. There is also
> 'angband', on, which is on my backend network.
> I have been developping my application on angband for the past months. What
> it does is start 2 threads, which connect to mysqld on utumno and angband
> and perform identical tasks. No problems here, all worked fine. It connects
> using mysql_real_connect with and as hostnames.
> I then moved to utumno for final testing, and the same program segfaults all
> the time. I traced it down to the mysql_real_connect and played with the
> hostname argument. It worked fine for, utumno, localhost,
> angband but NOT for
> Since this does not happen on angband, I assume it has to do with the fact I
> have two ethernet devices.
> Hope this helps....
> Thomas

Hi Thomas

This is definetly an DNS problem.
Perhaps you are asking the wrong nameserver?
Or do you have the IP defined in your hosts file on the utumno server?


Bug in MySQL concerning multiple ethernet devices (probably)Thomas van Gulick9 Sep
  • Re: Bug in MySQL concerning multiple ethernet devices (probably)Christian Mack13 Sep
  • Re: Security vulnerabilitySergei Golubchik1 Oct