MySQL Lists are EOL. Please join:

List:General Discussion« Previous MessageNext Message »
From:Blain Nelson Date:September 8 1999 4:53am
Subject:Re: Compiling error on Slackware 4.0
View as plain text  
sinisa@stripped wrote:
> 
> 
> Hi!
> 

Howdy.  And thanks for the reply.

> There are two possible causes of this. First, your gcc/g++ has not
> installed well. Try gcc 2.95 or some of the latest egcs compiler.

I did some dinking around for versions and stuff, and found these
things:
egcs-2.91.66
GNU Make version 3.76.1
and I was sure that I'd trapped out my gcc version, but can't seem to
find it now.  

> 
> It is possible that you have exhausted virtual memory or /tmp
> partition. In that case reconfigure mysql --with-low-memory.

On a hunch, I tried again using this setting and forcing it to use linux
threads instead of the MIT threads, and I got an even gnarlier error
statement on make:

c++ -DMYSQL_SERVER                -DDEFAULT_MYSQL_HOME="\"/usr/local\""
DDATADIR="\"/usr/local/var\""      
-DSHAREDIR="\"usr/local/share/mysql\""
                                 -DHAVE_CONFIG_H -I./../include
I./../regex                      -I. -I../include -I.. -I.   -O
-fno-implicit templates -DDBUG_OFF -c item.cc
item_func.h: In method `void Item_func_bit_or::fix_length_and_dec()':
In file included from item.h:304,
                 from mysql_priv.h:158,
                 from item.cc:19:
item_func.h:528: Internal compiler error.
item_func.h:528: Please submit a full bug report to
`egcs-bugs@stripped'
item_func.h:528: See <URL:http://egcs.cygnus.com/faq.html#bugreport> for
details.

Which, I must say, impressed me all to heck, but didn't make a bit of
sense.  I did go to the nifty url there, but, unfortunately, I'm not
fluent in geek enough to make heads or tails of what it was asking, so I
guess this is one bug that goes unreported.

So, on a hunch, I tried reinstalling the precompiled binary, and it
seems to be working just ducky (or was until I shutdown linux with it
operating -- it was sent the "mysql.server stop" command right like I
wanted it to and it refused permission and got killed anyhow.  We'll see
if it's as happy when I reload linux and try to get it to start
automagically as well).  For now, my problem is trying to get the
$EDITOR variable set to pico (yeah, elvis will do everything but wash my
dishes, but I'm not in the mood to learn modal editing at this
juncture), and as God is my witness, a simple "setenv $EDITOR=pico"
seems to be beyond the ability of what I've got going here.

I'm starting to think that this particular version of zipslack is just
inadequate (I mean, when they forget to put the games in, that should
tell you something).  So I'm gonna go grab a full copy of the a series
and maybe the d series and install them and see if that clears up some
of this bizarre behavior.

> 
> Start from a fresh tarball.
> 

That might have helped too -- I rm'ed config.cache and did a make clean
before I started, but that might be a touch less fresh than your
suggestion.  I'll give that a try next time I've got it loaded.

> Sinisa
> 

Thanks for your help.  

Take care,
Blain
-- 
Blain Nelson        blain@stripped        anon-20630@stripped
     Anger is a normal healthy emotion --
                                            -- Abuse is a choice.  
http://www.blainn.cc/abuse/       <-       Is abuse part of your life?
Thread
Compiling error on Slackware 4.0Blain Nelson6 Sep
  • Re: Compiling error on Slackware 4.0sinisa6 Sep
  • Re: Compiling error on Slackware 4.0Blain Nelson8 Sep
  • Re: Compiling error on Slackware 4.0Gerald Clark8 Sep