MySQL Lists are EOL. Please join:

List:General Discussion« Previous MessageNext Message »
From:Christian Hammers Date:November 10 2002 5:35pm
Subject:Package references deprecated errno@GLIBC_2.0 symbol because it uses errno without including errno.h
View as plain text  
Hello

The following bug was reported against the Debian mysql package bug
seems to be a generall problem.

bye,

-christian-

On Sun, Nov 10, 2002 at 02:32:08PM +0100, Luca Barbieri wrote:
> Package: libmysqlclient10
> Version: 3.23.53-3
> Severity: important
> 
> One or more programs or libraries in your package reference the
> deprecated errno@stripped symbol, which is no longer available in
> TLS-based versions of GNU libc.
> 
> This is caused by the program using errno without including errno.h
> and/or declaring errno on its own (e.g. extern int errno;).
> 
> The package should be corrected by removing all declarations of errno
> and adding a #include <errno.h> in every file that uses errno, before
> the first use of errno.
> 
> It might be possible to quickly fix the package by just compiling it
> with CC="gcc -include /usr/include/errno.h" but eventually the package
> source should be corrected.
> 
> For more information, see
> <http://lists.debian.org/debian-devel/2002/debian-devel-200211/msg00174.html>.

Thread
Package references deprecated errno@GLIBC_2.0 symbol because it uses errno without including errno.hChristian Hammers10 Nov