List:General Discussion« Previous MessageNext Message »
From:<sinisa Date:September 7 1999 10:06am
Subject:Re: Segmentation fault on SPARC Solaris 2.6 with 3.22.25
View as plain text  
Patrick Verdon writes:
 > 
 > Hi Sinisa,
 > 
 > > Hi!
 > > 
 > > Please try binary version.
 > 
 > When I installed the binary version and restarted Apache
 > all my Perl modules failed (I use mod_perl) - it 
 > couldn't find libmysqlclient.so.6 which doesn't seem 
 > to exist with the binary version. This isn't much good
 > to me.
 > 
 > > If that does not help,  use gcc 2.95 er  latest egcs for Solaris.
 > 
 > I am using gcc 2.95.
 > 
 > > Also, please follow instructions from manual, particularly those
 > > pertaining to Solaris 2.6 precisely.
 > 
 > Hmm. I've recompiled exactly as the manual suggests for Solaris 2.6
 > and it seems to be ok now. Should I trust this? 
 > 
 > Usually I compile like this and it works fine:
 > 
 > # ./configure --prefix=/usr/local/mysql; make; make install
 > 
 > > And please, report back.
 > 
 > Ok!
 > 
 > I have another question - mysqlbug reports this:
 > 
 > Some paths:  /bin/perl /usr/ccs/bin/make /usr/local/bin/gcc /usr/ucb/cc
 > GCC: Reading specs from /usr/local/lib/gcc-lib/sparc-sun-solaris2.6/2.95/specs
 > gcc version 2.95 19990728 (release)
 > Compilation info: CC='gcc'  CFLAGS=''  CXX='gcc'  CXXFLAGS=''  LDFLAGS=''
 > Configure command: ./configure  --with-unix-socket-path=/var/tmp/mysql.sock --wi
 > th-low-memory --with-mit-threads=yes
 > Perl: This is perl, version 5.005_03 built for sun4-solaris
 > 
 > However, I did not compile with mit-threads and shouldn't 
 > be as I'm running Solaris 2.6. Also, it doesn't report
 > the CFLAGS and CXXFLAGS I'm now using:
 > 
 > CFLAGS=-O6
 > CXXFLAGS=-O6 -felide-constructors -fno-exceptions -fno-rtti
 > 
 > Is this correct?
 > 
 > Cheers.
 > 
 > 
 > 
 > Patrick
 > 
 > -- 
 > 
 > #===============================#
 > \  KAN Design & Publishing Ltd  /
 > /  T: +44 (0)1223 511134        \
 > \  F: +44 (0)1223 571968        /
 > /  E: mailto:patrick@stripped  \ 
 > \  W: http://www.kan.co.uk      /
 > #===============================#
 > 

Why mit-threasd ???

Please, no. This is not what manual says.

Use native-threads !!!

Again: follow instructions from manual, point by point.

Regarding missing client lib, please check whether it is at all in
distribution.

If it is there, check where has it gone ! Add that directory to the
environment variable holding info on dynamic libs directoreis.

If it is not there, download clients  too.

Sinisa

+----------------------------------------------------------------------+
| TcX  ____  __     _____   _____  ___     ==  mysql@stripped            |
|     /*/\*\/\*\   /*/ \*\ /*/ \*\ |*|     Sinisa Milivojevic          |
|    /*/ /*/ /*/   \*\_   |*|   |*||*|     mailto:sinisa@stripped|
|   /*/ /*/ /*/\*\/*/  \*\|*|   |*||*|     Larnaka, Cyprus             |
|  /*/     /*/  /*/\*\_/*/ \*\_/*/ |*|____                             |
|  ^^^^^^^^^^^^/*/^^^^^^^^^^^\*\^^^^^^^^^^^                            |
|             /*/             \*\                Developers Team       |
+----------------------------------------------------------------------+
Thread
Segmentation fault on SPARC Solaris 2.6 with 3.22.25Patrick Verdon5 Sep
  • Re: Segmentation fault on SPARC Solaris 2.6 with 3.22.25sinisa6 Sep
  • Re: Segmentation fault on SPARC Solaris 2.6 with 3.22.25Patrick Verdon6 Sep
    • Re: Segmentation fault on SPARC Solaris 2.6 with 3.22.25sinisa6 Sep
  • Re: Segmentation fault on SPARC Solaris 2.6 with 3.22.25Patrick Verdon6 Sep
    • Re: Segmentation fault on SPARC Solaris 2.6 with 3.22.25sinisa7 Sep
    • Re: Segmentation fault on SPARC Solaris 2.6 with 3.22.25David Axmark13 Sep
  • Re: Segmentation fault on SPARC Solaris 2.6 with 3.22.25Patrick Verdon7 Sep