List:General Discussion« Previous MessageNext Message »
From:henk Date:September 2 1999 4:14pm
Subject:Re: MySQL-devel-3.23.2-alpha-1.i386.rpm / failed dependencies
View as plain text  
On Thu, 02 Sep 1999, you wrote:

Hi sinistra,

Thank you for answering, but that what is too easy for you seems to be too big
a problem for me. Obviously I allready tried to change the makefile before I
asked again. After spending hours trying to find the right entry's in the
makefile, I just can't get it to link.
Compilation works now, but linking not.

This is what I have in my makefile now.
INCLUDE1 = -I./fltk -I/usr/local/mysql-3.22.25/include/
-I/usr/local/mysql++-1.1/sqlplusint/ -I/usr/local/include/
LIBS = -L/usr/local/mysql-3.22.25/lib/mysql/ -L/usr/local/lib/ -L/usr/X11R6/lib
-L/usr/local/mysql++-1.1/sqlplusint/ -lmysqlclient -lm
-l/usr/local/mysql++-1.1/sqlplusint/mysql++ -lfltk -lXmu -lXt -lX11 -lXext

After compiling the error is:
/usr/bin/ld  cannot open -lmysql++:  no such file or dir

I tried many combinations of putting the full path or only the name of the
file in LIBS (especially for -lmysql++)

> henk writes:
>  > 
>  > > 
>  > > It seems that you do not have entire KDE installed from rpm's. You
>  > > could have probably built it from tarballs. Why don't you try instead
>  > > MySQL GUI, which is much better then KMySQL ;o)
>  > > 
>  > > And there is a new version under beta testing ..
>  > > 
>  > > Sinisa
>  > 
>  > Hi again,
>  > thank you for the answer, but...
>  > 
>  > Now sqlclient won't compile
>  > I installed and compiled fltk-1.0.4 and mysql++-1.1 (in /usr/local/..), both
>  > went fine. (My system is Red Hat 6.0.)
>  > 
>  > Then I tried to compile sqlclient-0.99 and got the following error
>  > 
>  > db_tree.cc:14: mysql++: No such file or directory
>  > db_tree.cc:16: syntax error before ''*'
>  > and a whole list of errors after that.
>  > 
>  > I then tried to change some things in the Makefile to get it to point to
>  > mysql++-1.1., etc. Als I made a link mysql++ to mysql++-1.1. 
>  > But don't know what exactly to change. Also I made a link mysql++ to
>  > mysql++-1.1. But it keeps complaining and won't compile.
>  > 
> 
> 
> Fix is too easy. 
> 
> Please edit Makefile and change INCLUDE! so that it points to the
> right directory, which is a directory containing mysql++ file.
> 
> Or download a Linux binary version from www.mysql.com.
> 
> If you are using glibc 2.0.7-20 or higher but less then 2.1.xx, I can
> send you a present. 
> 
> Sinisa
> 
> +----------------------------------------------------------------------+
> | TcX  ____  __     _____   _____  ___     ==  mysql@stripped            |
> |     /*/\*\/\*\   /*/ \*\ /*/ \*\ |*|     Sinisa Milivojevic          |
> |    /*/ /*/ /*/   \*\_   |*|   |*||*|     mailto:sinisa@stripped|
> |   /*/ /*/ /*/\*\/*/  \*\|*|   |*||*|     Larnaka, Cyprus             |
> |  /*/     /*/  /*/\*\_/*/ \*\_/*/ |*|____                             |
> |  ^^^^^^^^^^^^/*/^^^^^^^^^^^\*\^^^^^^^^^^^                            |
> |             /*/             \*\                Developers Team       |
> +----------------------------------------------------------------------+
Thread
MySQL-devel-3.23.2-alpha-1.i386.rpm / failed dependencieshenk1 Sep
  • MySQL-devel-3.23.2-alpha-1.i386.rpm / failed dependenciessinisa1 Sep
Re: MySQL-devel-3.23.2-alpha-1.i386.rpm / failed dependencieshenk2 Sep
  • Re: MySQL-devel-3.23.2-alpha-1.i386.rpm / failed dependencies(ATS)2 Sep
  • Re: MySQL-devel-3.23.2-alpha-1.i386.rpm / failed dependenciesMichael Widenius3 Sep
    • Re: MySQL-devel-3.23.2-alpha-1.i386.rpm / failed dependencieshenk3 Sep