List:General Discussion« Previous MessageNext Message »
From:Gerald Clark Date:September 11 2002 1:05pm
Subject:Re: can not connect or log into MySQL anymore.
View as plain text  
Do not run myisamchk with the server running.

Stephen Sokalski wrote:

> version: 3.23.37 running on an RAQ
> Problem:  I can not log into MySql as root - it hangs after I give it 
> a password.
> Background:  MySql was running fine for a year and then just stopped 
> running.
> Symptoms:   1) Mysqld is running when I reboot the server but can't be 
> shut down (/usr/share/mysql/mysql.server stop) and keeps timing out.
> 2) When it's running there is a .sock file
> 3) If I try to log in as any valid user, it simply waits indefinitely.
> 4) Suspecting that something is wrong with the mysql database, I ran a 
> check on it:
> myisamchk -f *.MYI and
> myisamchk -r *.MYI
> Every time I run the -r it states it's repairing indexes.
> In any event:
> I know I should probably upgrade the version but it was a "package" 
> that was suggested by sun at the time and I know I could
> download the binary but ... I want to make sure I understand what the 
> problem is and know that I will be able to fix it by upgrading.
> Can someone explain what is going on?  Will upgrading fix this 
> problem, etc.?
> Thanks,
> Steve
> ---------------------------------------------------------------------
> Before posting, please check:
>   (the manual)
>           (the list archive)
> To request this thread, e-mail <mysql-thread119238@stripped>
> To unsubscribe, e-mail 
> <>
> Trouble unsubscribing? Try:

can not connect or log into MySQL anymore.Stephen Sokalski11 Sep
  • Re: can not connect or log into MySQL anymore.Gerald Clark11 Sep
  • Re: can not connect or log into MySQL anymore.peter.brawley11 Sep