List:General Discussion« Previous MessageNext Message »
From:Chad Arimura Date:August 27 2002 6:32pm
Subject:Process Sleeping
View as plain text  
The search function for our ecommerce site has worked great up until the
other day, but now when a search is ran the whole system just hangs.  Here
is what I have found:

A process is started (search.cgi) that stays open until all of the memory is
used up (sometimes two same-named processes).  Then, it fills up ALL of the
swap space until the system is basically unsable.  After about 30 seconds of
filling up space and hanging the system, the process dies and the memory and
swap are released, returning the system to normal condition.

I ran "mysqladmin processlist" while the system was still responding (before
all swap filled), and all I found was a new mysql process sleeping, but not
doing anything.

I tried the exact same code with a backed-up version of the database from a
week ago, and the search worked fine.  Something in our DB changed and
messed stuff up, but so much is going on it's tough to figure out.

My question is, does anyone have a suggestion for pinpointing the problem?

Thanks in advance,
Chad Arimura

Process SleepingChad Arimura27 Aug
  • Re: Process SleepingDan Nelson27 Aug
    • RE: Process SleepingChad Arimura28 Aug
      • Re: Process SleepingDan Nelson28 Aug