List:General Discussion« Previous MessageNext Message »
From:Paul DuBois Date:August 13 2002 2:26am
Subject:Re: load data infile --- problem
View as plain text  
At 2:16 +0000 8/13/02, LR P wrote:
>hi all,
>i have a problem with "load data..." statement. i'm using MySQL 
>3.23.49 from RedHat 7.3. i read Paul DuBois book about MySQL, and 
>tried to load data to my member table,
>mysql> LOAD DATA INFILE "member.txt" INTO TABLE member;
>but i didn't work.

What was the error with LOCAL included?

>i've tried by removing the 'local', but it gave me same error message,
>ERROR 1045: Access denied for user: 'ihot@localhost' (Using password: YES)

When you remove LOCAL, then the file must be read by the server, in which
case you need the FILE privilege.

>i've given permission to user 'ihot' (from root), by using:
>mysql> GRANT ALL ON samp_db.* TO ihot@localhost IDENTIFIED BY "*******"

You'll need GRANT FILE ON *.* TO ihot@localhost; to give yourself
the FILE privilege.

>but still, it didn't work...
>Any idea, guys?

load data infile --- problemLR P13 Aug
  • Re: load data infile --- problemPaul DuBois13 Aug
Re: load data infile --- problemLR P14 Aug
  • Re: load data infile --- problemPaul DuBois14 Aug
    • RE: load data infile --- problemAron Pilhofer14 Aug
      • MysQL + OOoSabdy Serrano14 Aug
      • MysQL + OOoSabdy Serrano14 Aug