List:General Discussion« Previous MessageNext Message »
From:Dan Nelson Date:July 26 2002 2:22am
Subject:Re: 4.0.2 not found
View as plain text  
In the last episode (Jul 25), Darren Young said:
> I am in the process of testing out the 4.0 series of MySQL and am having
> some problems when I try to install the php-mysql RPM. The machine is a
> RedHat 7.2 i386 box with all current patches.
> I pulled down the source RPM for 4.0.2-2 and rebuilt the RPM's with debug
> enabled then installed all the necessary RPM's. Everything seems to be
> working ok on the MySQL side except that php is asking for
> and the only library installed with MySQL-shared is
> I tried a manual symlink from to
> and the php-mysql still complains that the library
> isn't present. I installed the php-mysql RPM with --nodeps just to test it
> out and sure enough I get 'Call to undefined function: mysql_pconnect' which
> is the same message you receive if you don't install the MySQL-shared RPM in
> the 3.0 series.
> I tried adding /usr/lib & /usr/lib/mysql  /etc/ and ran ldconfig
> which yielded the same results. Any thoughts on how I could get this library
> in place with 4.0.2?

The php you installed is linked to the mysql 3.23 shlibs.  Rebuild php
so it gets linked to the new lilbrary.

	Dan Nelson
4.0.2 not foundDarren Young25 Jul
  • Re: 4.0.2 not foundDan Nelson26 Jul