List:General Discussion« Previous MessageNext Message »
From:Bill Bernat Date:July 23 2002 8:04pm
Subject:RE: mysqldump question
View as plain text  
Hey, thanks *so* much for checking into this.

Your message did help.  In case you're curious.  First, I had the admin
create a 777 dump directory from root.  Still couldn't write out.  Then,
though, I just tried going to /tmp as you had done, and that was fine.
/tmp -- I feel like an idiot, but at least I'm an idiot who can dump the
database now:)

Also, do you happen to know how old is 3.23.21-beta-log?  Our MYSQL is
old, but I can't find out how old, is there a version history online


-----Original Message-----
From: Diana Soares [mailto:dcsoares@stripped] 
Sent: Tuesday, July 16, 2002 3:22 AM
To: Bill Bernat
Cc: mysql@stripped
Subject: Re: mysqldump question

On Tue, 2002-07-16 at 02:31, Bill Bernat wrote:
> Question:  is there anything I need to be aware of when writing dump 
> files to a local directory for my user, I'm having the following 
> problem.
> 1. I create a directory in my own home directory (linux, red hat 7.2) 
> ~/dumps and give it 777 permissions
> 2. I run " /usr/local/mysql/bin/mysqldump -uroot -p<<pass>> --tab 
> ~/dumps dbname table1 table2"
> 3. The .sql file for table1 gets created, correctly, in the dumps 
> directory fine.
> 4. mysqldump pukes when trying to write the .txt file:
> /usr/local/mysql/bin/mysqldump: Got error: 1: Can't create/write to 
> file '/home/bbernat/dumps/customer_relations_database.txt' (Errcode: 
> 13) when executing 'SELECT INTO OUTFILE'
> What have I done wrong and how can I fix it?


I was curious about your problem and decided to try it.
As user root (in the filesystem, redhat7.2), i created the dir ~/dumps
with 777 permissions and have run 
root@cartman:~# mysqldump -uroot -p --tab ~/dumps/ test 
(root mysqluser has FILE permissions). It gave me the same error. 

Then i tried with a common filesystem user (dsoares): dsoares@cartman:~$
mysqldump -uroot -p --tab ~/dumps/ test 

And it worked!
I went to see my /root permissions and it was: dsoares@cartman:~$ ll -d
drwxr-x---   31 root     root         4096 Jul 16 11:09 /root/

So the problem was there! mysql user doesn't have permissions to access
/root directory. Maybe this is your problem.

(also as root i tried with /tmp/dumps directory, 777 permissions, and it

Diana Soares
mysqldump questionBill Bernat16 Jul
  • Re: mysqldump questionDiana Soares16 Jul
RE: mysqldump questionBill Bernat23 Jul
  • Re: RE: mysqldump questionEgor Egorov24 Jul
  • RE: mysqldump questionDiana Soares24 Jul