List:General Discussion« Previous MessageNext Message »
From:Sasha Pachev Date:August 22 1999 4:08pm
Subject:Re: RedHat 6.0 Dual PIII and MySQL
View as plain text  
Bob Tanner wrote:
> I have a VaLinux box with dual PIII in it running RedHat 6.0. And I think
> there is a problem with MySQL-3.22.25-1 RPM in regards to multiple CPUs.
> Prehaps a thread problem?
> I tried to install MySQL via the web-site RPM and when it gets to the
> "mysql_install_db -IN-RPM" command, it just hangs.
> I broke on of the installed and inspected the .spec file and see that after
> running mysql_install_db the .spec file just changes some perms and starts the
> database, so I ran "bash -x mysql_install_db -IN-RPM" by hand to see what
> happens.
> Same result. Lokst of SQL commands, then:
> /usr/sbin/mysqld --bootstrap --skip-grant-tables <snip>
> command, top reported no CPU time for the command.
> I think this is a multiple CPU issue since the same RPM works fine on a single
> PIII VaLinux box running RedHat 6.0.
> I tried to search on the web site but none of the searching things work.
>, searching for CPU, I get no hits.
>, search for CPU, I also get no
> hits.
> Is there something I need to build differently for multiple CPUs?
> --
> Bob Tanner <tanner@stripped>       | Phone : (612)943-8700
>                | Fax   : (612)943-8500
> Key fingerprint =  6C E9 51 4F D5 3E 4C 66 62 A9 10 E5 35 85 39 D9

As far as I know, there is no code in MySQL that is specific to the
number of CPUs you have. If there is an issue that somehow comes up with
multiple CPUs, it will be a glibc or kernel issue.

Sasha Pachev
RedHat 6.0 Dual PIII and MySQLBob Tanner22 Aug
  • Re: RedHat 6.0 Dual PIII and MySQLTonu Samuel22 Aug
  • Re: RedHat 6.0 Dual PIII and MySQLSasha Pachev22 Aug
  • Re: RedHat 6.0 Dual PIII and MySQLVan22 Aug
  • Re: RedHat 6.0 Dual PIII and MySQLmysql22 Aug