List:General Discussion« Previous MessageNext Message »
From:Andrew Gartside Date:May 8 2002 12:49am
Subject: DROP DATABASE command executes but fails to drop database
View as plain text  
Windows 2K MySQL V ? (recent). Sorry, I'm not at my own machine at present,
can't check actual version number.

Installed, running and everything is ok, except I created a database called
'xyz' as a test then decided to delete it.
I used the command:	DROP DATABASE 'xzy'; 	which returns a message that
the command executed successfully, affecting however many rows were in the
database at the time. 
SHOW DATABASES; shows that the database is still there.

I then re-tried using command:	 DROP DATABASE if exists 'xyz'; 	with
the same result (no error messages).

I then tried using mysqladmin to do the job, with the same result.

I then used:	DELETE
		FROM mysql.db
		WHERE Db = "xyz";
which also executes successfully.

I test by using: 	SELECT db
		FROM mysql.Db;
which reveals that the database is NOT there. However! SHOW DATABASES; still
shows that the database is there!

I have also tried right click drop database in the GUI MySQL management
window. It fails to remove it.

I have stopped and re-started the service and the computer several times.
DROP DATABASE works fine for other databases I create and remove, just not
this one.

Is this a curly one? Any help appreciated.
DROP DATABASE command executes but fails to drop databaseAndrew Gartside8 May