List:General Discussion« Previous MessageNext Message »
From:Paul DuBois Date:April 9 2002 4:41pm
Subject:Re: Problems with Mac OS X
View as plain text  
At 9:31 -0700 4/9/02, Jim Dickenson wrote:
>On 4/8/2002 7:25 PM, "Paul DuBois" <paul@stripped> wrote:
>>  At 17:52 -0700 4/8/02, Jim Dickenson wrote:
>>>  I am having problems getting the "load data local infile" working.
>>>  I am running Mac OS X 10.1.3 build 5Q110 with all available updates
>>>  installed.
>>>  I had installed version 3.23.49 from
>>> and found that a change was
>>>  made in verion 3.23.49 as related to the use of local files. I added
>>>  --local-infile=1 when I run mysql and the command was accepted. The problem
>>>  I was then having is that if I issued the following command
>>>  load data local infile 'mt2308.dat' into table mt2308 ;
>>>  mt2308.dat was not found. I had to specify the fully qualified 
>>>file name for
>>>  the command to work. This is a change from the way it used to work as I
>>>  recall. It was the case that at one time this command would find 
>>>the file if
>>>  the file was in the current working directory.
>>  I don't have any problem with unqualified filenames under Mac OS X.
>>  Still works like it used to.
>>  Perhaps --local-infiile=1 isn't actually having any effect, so the server
>>  is still really  reading the file.  Do you have the FILE privilege?  If
>>  so, that might be the case.  You can test that by making the file mode
>>  600 so it's readable only to you, and then loading the file with the
>>  full pathname.  If that's what's happening, the server will no longer
>>  be able to read it.  (Assuming it doesn't run as you.)
>>  I suppose another possibility is that you're not really running mysql
>>  in the same directory where the file is located, although that seems
>>  unlikely -- unless maybe "mysql" is actually aliases to something
>>  weird.
>I had some other version of mysql executables in /usr/local/bin so I was not
>running the application I thought I was. Thanks for making me look at what
>really got executed when I said mysql.

Heh.  Wait until you start running about 10 different versions. :-)

>>>  I then went to and looked at what binary distributions were
>>>  there for Mac OS X. First I downloaded version 3.23.49 but when I tried to
>>>  run that version /usr/lib/libpthread.A.dylib was not found. I 
>>>could not find
>>>  where I could get this library.
>>>  I then picked up version 3.23.47 and although I did not need to use
>>>  --local-infile=1 the file was not find unless I specified the fully
>>>  qualified file name.
>>>  Two questions. First, what can I do to get the MySQL version 
>>>3.23.49 working
>>>  on my system so I have the current version of the software? 
>>>Second, what can
>>>  be done so I do not need to specify the fully qualified file name?
>This still leaves the question as to when version 3.23.49a will be compiled
>for Mac OS X, instead of version 3.23.47.

I always compile my own.  Is there some reason you don't do that?

Problems with Mac OS XJim Dickenson9 Apr
  • Re: Problems with Mac OS XPaul DuBois9 Apr
    • Re: Problems with Mac OS XJim Dickenson9 Apr
      • Re: Problems with Mac OS XPaul DuBois9 Apr
        • Re: Problems with Mac OS XJim Dickenson9 Apr
          • Re: Problems with Mac OS XPaul DuBois9 Apr