List:MySQL ODBC« Previous MessageNext Message »
From:Christian Mack Date:August 3 1999 2:43pm
Subject:Re: invalid string or buffer length
View as plain text  
System Administrator wrote:
> Hi,
> I am using Solaris 2.7 with ColdFusion 4.0 and Myodbc-2.50.22a and
> iodbc-2.12.
> I am trying to insert a very large file into a table and I am getting
> the following message:
> Error Diagnostic Information
> ODBC Error Code = S1090 (Invalid string or buffer length)
> [TCX][MyODBC]SQLBindParameter not used for all parameters
> Does anyone know how to rectify this?  Also  I have tried changing some
> parameters, for examples I boot up mysql with the following arguments:
> nohup $ledir/mysqld -O net_buffer_length=16M -O max_allowed_packet=512M
> -O max_sort_length=2048 --basedir=$MY_BASEDIR_VERSION --datadir=$DATADIR
> "$@" >> $err_log 2>&1
> and I still get the same error above... Is there an way to change the
> MYODBC buffer length?
> Thank you very much.
> Edward Valentini

Hi Edward

Yes, you can specify it in the my.cnf configuration file on the client site:
set-variable = max_allowed_packet=512M

If you enable the option "Read options from my.cnf" in the DSN.


invalid string or buffer lengthSystem Administrator2 Aug
  • invalid string or buffer lengthMichael Widenius3 Aug
  • Re: invalid string or buffer lengthChristian Mack3 Aug