List:MySQL ODBC« Previous MessageNext Message »
From:Michael Widenius Date:August 2 1999 10:12pm
Subject:invalid string or buffer length
View as plain text  
>>>>> "System" == System Administrator <sysadm@stripped>
> writes:

System> Hi,

System> I am using Solaris 2.7 with ColdFusion 4.0 and Myodbc-2.50.22a and
System> iodbc-2.12.

System> I am trying to insert a very large file into a table and I am getting
System> the following message:

System> Error Diagnostic Information
System> ODBC Error Code = S1090 (Invalid string or buffer length)
System> [TCX][MyODBC]SQLBindParameter not used for all parameters

System> Does anyone know how to rectify this?  Also  I have tried changing some
System> parameters, for examples I boot up mysql with the following arguments:

System> nohup $ledir/mysqld -O net_buffer_length=16M -O max_allowed_packet=512M
System> -O max_sort_length=2048 --basedir=$MY_BASEDIR_VERSION --datadir=$DATADIR
System> "$@" >> $err_log 2>&1

System> and I still get the same error above... Is there an way to change the
System> MYODBC buffer length?

System> Thank you very much.

System> Edward Valentini


The above error means that your applications (Coldfusion) is calling the ODBC
functions in the wrong order or that you haven't escaped your BLOB


invalid string or buffer lengthSystem Administrator2 Aug
  • invalid string or buffer lengthMichael Widenius3 Aug
  • Re: invalid string or buffer lengthChristian Mack3 Aug