List:Internals« Previous MessageNext Message »
From:AugustQ Date:February 5 2013 3:46pm
Subject:source does not compile
View as plain text  

I know that this is a beginners-question but please allow me to post it:
the source-code of MySQL does not compile on my machine here.

Everything worked fine in the past until I had a crassh on the hard-disk
so I bought a new one and created everything from scratch, the OS, all
applications etc., all of the latest versions.

For (re)installing the source-code of MySQL I followed the rules given

The version of MySQL here is: mysql-5.5.0-m2.tar
With this version of the source everything worked fine on the old

I now have this structure: HOME/workspace/MySQL-Src/mysql-5.5.0-m2
and there I have all the sources in it.

Following the the steps described in the web-site I added the group
mysql and the user mysql on the machine. Next is the configure-step
which runs through, I did not see any errors or warnings. The next step
is make and it delivers 2 warnings and then stops at the label
do_abi_check in the Makefile. This is what it delivers (shortened):

....... start ......................
set -ex; \
	for file in include/mysql/plugin.h include/mysql.h; do \
	         gcc -E -nostdinc -dI \
	                  -I./include \
	                  -I./include/mysql \
....... removed some lines ..........
+ for file in include/mysql/plugin.h include/mysql.h
+ gcc -E -nostdinc -dI -I./include -I./include/mysql -I./sql -I./include
-I./include/mysql -I./sql include/mysql/plugin.h
+ /bin/sed -e '/^# /d' -e '/^[ 	]*$/d' -e '/^#pragma GCC
set_debug_pwd/d' -e '/^#ident/d'
+ /usr/bin/diff -w include/mysql/plugin.h.pp ./abi_check.out
< #include <stdlib.h>
< extern struct my_snprintf_service_st {
....... removed some lines ..........
< void mysql_query_cache_invalidate4(void* thd,
<                                    const char *key, unsigned int
<                                    int using_trx);
make[2]: *** [do_abi_check] Fehler 1
make[2]: Verlasse Verzeichnis
make[1]: *** [abi_check] Fehler 2
make[1]: Verlasse Verzeichnis
make: *** [all-recursive] Fehler 1
....... end ........................

What's wrong here? Can someone please give me a tip.


source does not compileAugustQ5 Feb
  • Re: source does not compileMarc Alff6 Feb
    • Re: source does not compileBjorn Munch6 Feb
Re: source does not compileAugustQ8 Feb