MySQL Lists are EOL. Please join:

List:Bugs« Previous MessageNext Message »
From:Richard Runds Date:February 11 2000 3:37pm
Subject:can't start mysqld at all
View as plain text  

My name is Richard and I'm a system administrator at Naturvetarsektionen,
which is a student organisation at University of Gothenburg, Sweden.

We are running RedHat 6.1 on a SPARCStation 5.

The libraries we use is glibc-2.1.2-15, which is installed as a
RPM-package, distributed toghether with RH6.1.

The compiler is egcs-2.91.66, also distributed with RH 6.1.

Due to the lack of a binary distribution for our system, I compiled the
Source-RPM of MySQL, version 3.22.30-1. 

There is no way to install the grant tables. 
The output from the postinstallation-script (using rpm) is:

+ mysql_install_db -IN-RPM
Creating db table
Creating host table
Creating user table
Creating func table
Creating tables_priv table
Creating columns_priv table
Installation of grant tables failed!

I also tried to do this manually.
The logs only say when the server started and ended, nothing else.

When I start mysqld I got the message:
Segmentation fault (core dumped)

I also get this message if I run /usr/sbin/mysqld --skip-grant &

I don't know what to do. (???)

When I run gdb with the coredump as input I get:

Core was generated by `/usr/sbin/mysqld'.
Program terminated with signal 11, Segmentation fault.
#0  0x0 in ?? ()
(gdb) bt
#0  0x0 in ?? ()
#1  0xaa450 in pthread_setcanceltype (type=-800481215, oldtype=0xd0264000)
    at cancel.c:40
Cannot access memory at address 0xd001a078.

When I do run I get:

(gdb) run --skip-grant
Starting program: /usr/sbin/mysqld --skip-grant

Program received signal SIGSEGV, Segmentation fault.
0xaa464 in pthread_setcanceltype (type=1, oldtype=0xefffebb4) at
42      cancel.c: No such file or directory.
(gdb) bt
#0  0xaa464 in pthread_setcanceltype (type=1, oldtype=0xefffebb4)
    at cancel.c:42
#1  0xa9f20 in fcntl (fd=0, cmd=1) at wrapsyscall.c:77
#2  0xafb2c in check_standard_fds () at
#3  0xafc7c in __libc_start_main (main=0x3b080 <main>, argc=2, 
    argv=0xefffecf4, init=0x100b4 <_init>, fini=0xfeccc <_fini>,
    stack_end=0xefffed9c) at ../sysdeps/generic/libc-start.c:60

The same output is generated if I don't use --skip-grant.


can't start mysqld at allRichard Runds11 Feb
  • Re: Unable to create Database through winmysqladmin1.4 utility(Databases section) !!!miguel solorzano16 May