List:Replication« Previous MessageNext Message »
From:Albert van Dam Date:December 11 2004 4:39pm
Subject:My replication nightmare
View as plain text  
Hi

I've got four machines, two with me in South Africa and two in Croatia
running on two different systems.

Both systems are exact replicas of each other with the following two
exeptions:
* The data in the database is different (clearly as it is different users)
* The machines in Croatia are both HP Proliant DL360, Single Xeon 3.4GHz,
1GB RAM, 72GB SCSI RAID with SuSE 9.1 as OS and MySQL 4.1.5 Gamma
* The one machine in South Africa is Pentium II 266, 128MB RAM, 10GB IDE HDD
with RedHat 9 as OS and MySQL 4.1.5 Gamma
* The other machine in South Africa is a Centrino 1.6, 512MB RAM, 40GB IDE
HDD with Windows XP as OS and MySQL 4.1.7-essential.

The machines in South Africa are used for R&D and the machines in Croatia
are production units.

The IP's on both networks are the same, the config for the master is the
same on both masters and the config for the slaves are the same on both
slaves.

Master IP: 192.168.100.201
Replication user: repl	password: replic	REPLICATION SLAVE
Master config:
[mysqld]
skip-locking
key_buffer = 16M
max_allowed_packet = 1M
table_cache = 64
sort_buffer_size = 512K
net_buffer_length = 8K
myisam_sort_buffer_size = 8M

log-bin
server-id=1

max-relay-log-size=500M
max-binlog-size=500M
log-warnings
skip-innodb
skip-bdb

Slave IP: 192.168.100.200
Slave config:
[mysqld]
skip-locking
key_buffer = 16M
max_allowed_packet = 1M
table_cache = 64
sort_buffer_size = 512K
net_buffer_length = 8K
myisam_sort_buffer_size = 8M

log-bin
server-id=2

master-host=192.168.100.201
master-port=3306
master-user=repl
master-password=replic
master-connect-retry=60

max-relay-log-size=500M
max-binlog-size=500M
log-warnings
read-only
relay-log-purge=1
relay-log-space-limit=1000M
slave-net-timeout=10
skip-innodb
skip-bdb

The replication in South Africa works 100%. The replication in Croatia does
not work. I keep getting an "IO error cannot connect to
repl@stripped:3306" error.

Can anyone give me some pointers as to what I should do to get this working?

This is rather urgent as the customer is screaming in my ears because their
system is not working.

Thanks in advance

Albert

---
Outgoing mail is certified Virus Free.
Checked by AVG anti-virus system (http://www.grisoft.com).
Version: 6.0.805 / Virus Database: 547 - Release Date: 2004/12/03
 

Thread
My replication nightmareAlbert van Dam11 Dec