List:Replication« Previous MessageNext Message »
From:Chen Abella Date:February 7 2006 6:22am
Subject:Slave I/O thread killed while connecting to master
View as plain text  
      
hi

i get the following messages in my log:

060206 19:46:13 [Warning] Found invalid password for user: 'root@server2'; Ignoring user
060206 19:47:10 [Note] /usr/libexec/mysqld: Normal shutdown

060206 19:47:10 [ERROR] Slave I/O thread killed while connecting to master
060206 19:47:10 [ERROR] Slave I/O thread exiting, read up to log 'server1-bin.000001',
position 477
060206 19:47:10 [ERROR] Error reading relay log event: slave SQL thread was killed
060206 19:47:10 [Note] /usr/libexec/mysqld: Shutdown complete
 
is this a DNS problem still??
 
 thanks

Kishore Jalleda <kjalleda@stripped> wrote: its is clear that mysql is not resolving
the servers FQDN , so either replace the servers FQDN ( server1.group.org) with the real
IP address or make sure that mysql is doing dns resolution properly (  
http://dev.mysql.com/doc/refman/5.0/en/dns.html ) 
  
 Kishore Jalleda

 
 On 2/6/06, Chen Abella <shandy_1023@stripped> wrote: 
hi. i am using mysql-4.1.11 in fc4.
i have two servers, server1 and server2.
i have trouble with replication. i followed the steps in 
http://dev.mysql.com/doc/refman/5.0/en/replication-howto.html.
when i type show processlist, I/O slave status is connecting to master.
here are the error in the log message: 

060206 17:23:43 [ERROR] Slave I/O thread: error connecting to master
'root@stripped:3306': Error: 'Can't connect to MySQL server on '
server1.group.org' (13)'  errno: 2003  retry-time: 60  retries: 86400
060206 17:23:43 [Note] Slave SQL thread initialized, starting replication in log
'server1-bin.000001' at position 477, relay log './server2-relay-bin.000001 ' position: 4
060206 17:40:58 [ERROR] Slave I/O thread: error connecting to master
'root@stripped:3306': Error: 'Unknown MySQL server host ' server1.group.org'
(2)'  errno: 2005  retry-time: 60  retries: 86400
this is weird because when i manually connect from server1 to server2 and vice versa, i
can connect using the following command:
mysql --host=serverX --user=root --password=123456 
how do i fix this problem?...

help please... =(
thanks




chEn
Send instant messages to your online friends http://uk.messenger.yahoo.com
 

 


 chEn 
Send instant messages to your online friends http://uk.messenger.yahoo.com 
Thread
replication log errorChen Abella6 Feb
  • Re: replication log errorKishore Jalleda6 Feb
    • Slave I/O thread killed while connecting to masterChen Abella7 Feb
    • replication trouble.. DNS?Chen Abella7 Feb