List:Replication« Previous MessageNext Message »
From:Wagner Bianchi Date:September 1 2011 2:44pm
Subject:Re: Having trouble setting up a replication environment
View as plain text  
Folks,

Since the MySQL 5.1, the MySQL's $DATADIR is located
at C:/ProgramData/MySQL/MySQL Server 5.1/Data/, that is, at the Windows'
Data Folder.

Could you check if you find the master.info at that location, please?

Best wishes,
--
Wagner Bianchi - +55 (31) 8654 - 9510
*LinkedIn*: http://br.linkedin.com/in/wagnerbianchi
*Twitter*: @wagnerbianchijr
*Skype*: wbianchijr



2011/9/1 Truls Bergskaug <truls@stripped>

> On 09/01/2011 11:54 AM, Robert Miesen wrote:
>
>> Thank you for your help.
>>
>> I searched the installation directory for the master.info file (running
>> MySQL v5.5, on a Windows Server) and couldn't find it anywhere, even though
>> I setup the slave using the appropriate additions to the my.cnf file and
>> running the CHANGE MASTER TO statement.
>>
>> Do you know where the master.info file should be on a Windows Server.
>>
> It's usually where the database files are.
>
>
>> On 09/01/2011 01:56, Truls Bergskaug wrote:
>>
>>> On 08/30/2011 10:08 AM, Robert Miesen wrote:
>>>
>>>> I've done so and have confirmed that I can login and have the GRANTS I
>>>> expect to have.
>>>> ...
>>>>
>>>>>
>>>>>> Every time I try and start the replication process on the slave
> side
>>>>>> of things, I get the following error message:
>>>>>>
>>>>>> Slave I/O: error connecting to master
> 'repl@*ip_address_redacted*:**3306'
>>>>>> - retry-time: 60  retries: 86400, Error_code: 1045
>>>>>>
>>>>>
>>> Error: |1045| SQLSTATE: |28000| (|ER_ACCESS_DENIED_ERROR| <
>>> http://dev.mysql.com/doc/**refman/5.1/en/error-messages-**
>>>
> server.html#error_er_access_**denied_error<http://dev.mysql.com/doc/refman/5.1/en/error-messages-server.html#error_er_access_denied_error>>)
>>>
>>>
>>> Message: Access denied for user '%s'@'%s' (using password: %s)
>>>
>>> The only privilege the replication user need is "REPLICATION SLAVE".
>>> In the file "master.info" in your data directory on the slave;
>>> servername, username, password and port is stored. Please verify that these
>>> values are what you can use to connect to the master.
>>>
>>>
>>>>>>
>>>>>>
>>>>>> I've verified that I can login using the repl account from the
> machine
>>>>>> in question, so I know that the repl account can login from the
> Windows
>>>>>> Server machine to the Master MySQL server. My question is, what
> could be
>>>>>> causing this sort of error if it's not a credentials issue?
>>>>>>
>>>>>> Thanks in advance for your help!
>>>>>>
>>>>>
>>>>>
>>>
>>>
>>
>
> --
> MySQL Replication Mailing List
> For list archives:
> http://lists.mysql.com/**replication<http://lists.mysql.com/replication>
> To unsubscribe:    http://lists.mysql.com/**replication?unsub=1
> wagnerbianchijr@stripped<http://lists.mysql.com/replication?unsub=1
>
>

Thread
Having trouble setting up a replication environmentRobert Miesen29 Aug
  • Re: Having trouble setting up a replication environmentTruls Bergskaug29 Aug
    • Re: Having trouble setting up a replication environmentANIL YADAV29 Aug
      • Re: Having trouble setting up a replication environmentRobert Miesen30 Aug
    • Re: Having trouble setting up a replication environmentRobert Miesen30 Aug
      • Re: Having trouble setting up a replication environmentTruls Bergskaug1 Sep
        • Re: Having trouble setting up a replication environmentRobert Miesen1 Sep
          • Re: Having trouble setting up a replication environmentTruls Bergskaug1 Sep
            • Re: Having trouble setting up a replication environmentWagner Bianchi1 Sep
              • Re: Having trouble setting up a replication environmentRobert Miesen1 Sep
  • Re: Having trouble setting up a replication environmentAndrej Pintar29 Aug
    • Re: Having trouble setting up a replication environmentRobert Miesen30 Aug
      • RE: Having trouble setting up a replication environmentMohammed Bajwa30 Aug
        • Re: Having trouble setting up a replication environmentJohan De Meersman30 Aug
  • Re: Having trouble setting up a replication environmentDatabase System1 Sep