List:Replication« Previous MessageNext Message »
From:Robert Miesen Date:August 30 2011 8:09am
Subject:Re: Having trouble setting up a replication environment
View as plain text  
I've verified that the 'repl' user has the "REPLICATION SLAVE" GRANT.

On 08/29/2011 02:12, ANIL YADAV wrote:
> Hi Truls
>
>
> Also make sure u have created used on master server with required
> privileges.
>
> On Mon, Aug 29, 2011 at 2:40 PM, Truls Bergskaug<truls@stripped>  wrote:
>
>> On 08/29/2011 07:42 AM, Robert Miesen wrote:
>>
>>> Hi.
>>>
>>> I am attempting to setup a MySQL replication environment between a v5.1
>>> master (running on a Linux machine) and a v5.5 slave (running on a Windows
>>> Server machine) and nothing I do seems to work here. I've modified the
>>> master server's my.cnf file as follows:
>>>
>>> replicate-do-db=lm_store
>>> replicate-ignore-table=lm_**store.user
>>> replicate-ignore-table=lm_**store.usergroup
>>> replicate-ignore-table=lm_**store.usergroupasm
>>> log-bin=MySQL-bin
>>> server-id=1
>>> ...
>>> port=3306
>>>
>>>
>>> I modified the slave's my.cnf file as follows:
>>>
>>> [mysqld]
>>> server-id=2
>>>
>>>
>>> I setup a replication user called "repl"@"%.*domain_name_**redacted*"
>>> with replication slave permissions. I also configured the slave to use the
>>> master using the following query:
>>>
>>> CHANGE MASTER TO
>>> MASTER_HOST    = '*ip_address_redacted*',
>>> MASTER_USER    = 'repl',
>>> MASTER_PASSWORD= '*redacted*',
>>> MASTER_LOG_FILE= ' MySQL-bin.000001',
>>> MASTER_LOG_POS = 4236;
>>>
>>>
>>> Every time I try and start the replication process on the slave side of
>>> things, I get the following error message:
>>>
>>> Slave I/O: error connecting to master 'repl@*ip_address_redacted*:**3306'
>>> - retry-time: 60  retries: 86400, Error_code: 1045
>>>
>>> For more information, see Help and Support Center athttp://www.mysql.com.
>>>
>>>
>>> I've verified that I can login using the repl account from the machine in
>>> question, so I know that the repl account can login from the Windows Server
>>> machine to the Master MySQL server. My question is, what could be causing
>>> this sort of error if it's not a credentials issue?
>>>
>>> Thanks in advance for your help!
>>>
>> try using the mysql client on the slave to log in to the master with the
>> same username/password:
>> mysql -h*ip_address_redacted* -urepl -p
>>
>> Then you can chek if connection and credentials work as expected.
>>
>> Truls Bergskaug
>> Basefarm AS
>>
>
>

-- 

Thread
Having trouble setting up a replication environmentRobert Miesen29 Aug
  • Re: Having trouble setting up a replication environmentTruls Bergskaug29 Aug
    • Re: Having trouble setting up a replication environmentANIL YADAV29 Aug
      • Re: Having trouble setting up a replication environmentRobert Miesen30 Aug
    • Re: Having trouble setting up a replication environmentRobert Miesen30 Aug
      • Re: Having trouble setting up a replication environmentTruls Bergskaug1 Sep
        • Re: Having trouble setting up a replication environmentRobert Miesen1 Sep
          • Re: Having trouble setting up a replication environmentTruls Bergskaug1 Sep
            • Re: Having trouble setting up a replication environmentWagner Bianchi1 Sep
              • Re: Having trouble setting up a replication environmentRobert Miesen1 Sep
  • Re: Having trouble setting up a replication environmentAndrej Pintar29 Aug
    • Re: Having trouble setting up a replication environmentRobert Miesen30 Aug
      • RE: Having trouble setting up a replication environmentMohammed Bajwa30 Aug
        • Re: Having trouble setting up a replication environmentJohan De Meersman30 Aug
  • Re: Having trouble setting up a replication environmentDatabase System1 Sep