List:Replication« Previous MessageNext Message »
From:Database System Date:April 1 2010 8:29pm
Subject:Re: 回复: CREATE TABLE didn't replicated i
nside do-db database
View as plain text  
I did use db, and then create table.

--- On Thu, 4/1/10, Timo <greycd@stripped> wrote:


From: Timo <greycd@stripped>
Subject: 回复: CREATE TABLE didn't replicated inside do-db database
To: "Database System" <database100@stripped>, "replication"
<replication@stripped>
Date: Thursday, April 1, 2010, 12:51 PM





#yiv849275076 BLOCKQUOTE{margin-Top:0px;margin-Bottom:0px;margin-Left:2em;}#yiv849275076
#yiv849275076 {FONT-SIZE:12pt;FONT-FAMILY:宋体, serif;}#yiv849275076 


Hi lisa:
 
 
 
This is the bug of version 5.0.37.
 
If you run 'create db.table', the slave will not to replicate the table. You should run
'use db; create table'. And  version 5.0.90 has fixed this bug.
 
2010-04-02


Best regards
Timo Seven
blog: http://zauc.wordpress.com
#####请翻墙浏览,或者指定hosts到74.200.243.252#######
UNIX System Admin & MySQL DBA



发件人: Database System <database100@stripped>
发送时间: 2010-04-02 00:20
主 题: CREATE TABLE didn't replicated inside do-db database
收件人: replication@stripped



Hi, 
 
I found CREATE TABLE on master didn't replicated to slave. On slave server ini file, I have replicate-do-db = db_name. When new table is created in this database, it didn't replicated to slave. Updating on exist tables are replicated.  
 
On a different server, slave didn't setup replicate-do-db, the CREATE TABLE was replicated to slave. The privilege on replication account is the same. 
 
The version I use is V5.037. 
 
Any ideas? 
 
Thanks, 
Lisa 
 
 
 
 
       
 
--  
MySQL Replication Mailing List 
For list archives: http://lists.mysql.com/replication 
To unsubscribe:    http://lists.mysql.com/replication?unsub=1
 
 



      
Thread
回复: CREATE TABLE didn't replicated inside do-db databaseTimo1 Apr
  • Re: 回复: CREATE TABLE didn't replicated inside do-db databaseDatabase System1 Apr
  • Re: CREATE TABLE didn't replicated inside do-db databaseHai Zhang6 Apr
    • Re: CREATE TABLE didn't replicated inside do-db databaseMiguel Angel Nieto3 May