List:MySQL++« Previous MessageNext Message »
From:Warren Young Date:March 3 2005 6:21am
Subject:Re: error attempting to make mysql++ 1.7.30
View as plain text  
Chris Gagnon wrote:

> Anyways my environment is FreeBSD 4.9

That comes with both g++ 2.95.x and 3.x.  Are you sure you're using the 
3.x compiler?  MySQL++ is known to have problems with GCC 2.95.x.

> resiter.h:55: no class template named `iterator' in `std'

Section 24.3.2 of the ISO standard says differently.  You have a 
non-conforming implementation.
Thread
error attempting to make mysql++ 1.7.30Chris Gagnon3 Mar
Re: error attempting to make mysql++ 1.7.30Warren Young3 Mar