List:MySQL++« Previous MessageNext Message »
From:Warren Young Date:December 7 2004 8:40pm
Subject:Re: Configure script problem and (maybe) patch
View as plain text  
I made the patch slightly different:

diff -u -r1.25 configure.in
--- configure.in        20 Nov 2004 23:51:19 -0000      1.25
+++ configure.in        7 Dec 2004 20:38:06 -0000
@@ -32,12 +32,12 @@

  AC_ARG_WITH(mysql-lib,
      [  --with-mysql-lib=<path> directory path of MySQL library 
installation],
-    [MYSQL_lib_check=$with_mysql/lib/mysql])
+    [MYSQL_lib_check=$with_mysql_lib/lib])

  AC_ARG_WITH(mysql-include,
      [  --with-mysql-include=<path>
                            directory path of MySQL header installation],
-    [MYSQL_inc_check=$with_mysql/include/mysql])
+    [MYSQL_inc_check=$with_mysql_include/include])

  AC_MSG_CHECKING([for MySQL library directory])
  MYSQL_libdir=

Does this also work for you?  If not, I think the patch should be 
extended to include your version, rather than going with the way you did it.

By the way, please provide patches in unified diff format next time, and 
be sure to get the order correct.  Yours appeared to be some other type 
of context diff, and was reversed.
Thread
Configure script problem and (maybe) patchSteve Roberts7 Dec
  • Re: Configure script problem and (maybe) patchWarren Young7 Dec
RE: Configure script problem and (maybe) patchSteve Roberts7 Dec
  • Re: Configure script problem and (maybe) patchWarren Young7 Dec
  • Re: Configure script problem and (maybe) patchWarren Young7 Dec
RE: Configure script problem and (maybe) patchSteve Roberts7 Dec
  • Re: Configure script problem and (maybe) patchWarren Young7 Dec