List:MySQL and Perl« Previous MessageNext Message »
From:Jochen Wiedmann Date:August 24 1999 12:11pm
Subject:Re: DBI/Mysql error: install_driver(mysql) failed...
View as plain text  
TJ Cox wrote:

> Upon reviewing many a posting by you guys and searching the documentation
> , mainly the README in the Msql-Mysql-modules directory these are what we
>  have looked into:
> 
> 1.  The README suggests this error is caused by Perl being compiled in so
> mething other than gcc.  We have checked our perl (perl -V) and it looks
> as if gcc (version 2.7.2.1) was used during compilation.  It assures us t
> hat Binary distributions of Mysql are done in gcc.  Thus, this doesn't se
> em to be the problem unless they are different versions of gcc.  Anyone k
> now how to find the compilation version of my MySQL?

gcc is not the only portability issue. For example the libc version is
another question. The answer always remains the same: Roll your own
versions of perl, mysql and DBD::mysql and don't use precompiled binaries
(unless distributed as part of your system, of course).


Sorry,

Jochen



-- 
Jochen Wiedmann						joe@stripped
Life has brown and green eyes. :-)			+49 7123 14887


Thread
DBI/Mysql error: install_driver(mysql) failed...TJ Cox23 Aug
  • Re: DBI/Mysql error: install_driver(mysql) failed...Jochen Wiedmann24 Aug
    • Re: DBI/Mysql error: install_driver(mysql) failed...Eric Siegerman24 Aug
      • Re: DBI/Mysql error: install_driver(mysql) failed...artlore24 Aug
    • Re: DBI/Mysql error: install_driver(mysql) failed...TJ Cox25 Aug
      • Re: DBI/Mysql error: install_driver(mysql) failed...Jochen Wiedmann26 Aug