List:NDB Connectors« Previous MessageNext Message »
From:Monty Taylor Date:October 22 2007 6:18am
Subject:Re: configure fails with AC_PROG_SWIG
View as plain text  
Ah... I don't really even know what branch that is, but there's only two 
active branches anymore. There's the devel branch, which is the stable 

and the ndbjmerge branch which is where all of my more crazy hacking 
goes before it gets in to devel.

I would recommend the devel branch unless you want to install the 
patched version of MySQL I have in my PPA at:

deb gutsy universe main
deb-src gutsy universe main

(feisty and dapper also work)

OR - you want to build from source from a recent pull from the telco 
trees. (I added some methods to the C++ API and I'm using them in the 
ndbjmerge branch already - but they should be in 5.1.23, as I've also 
merged with mysql-5.1-new-ndb)


Jim Dowling wrote:
> Hi Monty,
> No I tried to get the ndbj branch:
> bzr branch http://...../ndbj
> and the m4 directory wasn't part of the branch.
> Can you make it part of the branch or mail me it?
> Cheers
> Jim
> Monty Taylor wrote:
>> Hey Jim,
>> Do you not have it in m4/ac_pkg_swig.m4?
>> mtaylor@solace:~/src/ndb-connectors/ndbjmerge/m4$ grep AC_PROG_SWIG *
>> ac_pkg_swig.m4:dnl @synopsis AC_PROG_SWIG([major.minor.micro])
>> ac_pkg_swig.m4:dnl If the version argument is given (e.g. 1.3.17), 
>> AC_PROG_SWIG checks
>> ac_pkg_swig.m4:dnl             AC_PROG_SWIG(1.3.17)
>> ac_pkg_swig.m4:AC_DEFUN([AC_PROG_SWIG],[
>> ac_pkg_swig.m4:        AC_REQUIRE([AC_PROG_SWIG])
>> ac_pkg_swig.m4:        AC_REQUIRE([AC_PROG_SWIG])
>> ac_pkg_swig.m4:        AC_REQUIRE([AC_PROG_SWIG])
>> If not, perhaps you have a b0rked branch? Did you run ./ 
>> before configure?
>> Monty
>> Jim Dowling wrote:
>>> Hi Monty,
>>> I've tried building ndbconnectors, but it fails with no knowledge of 
>>> the AC_PROG_SWIG macro. Where is it defined? I looked in the m4 files 
>>> and couldn't find it.
>>> jdowling@localhost:~/dev/ndbconnectors/devel$ swig -version
>>> SWIG Version 1.3.31
>>> Compiled with g++ [i686-pc-linux-gnu]
>>> Please see for reporting bugs and further 
>>> information
>>> jdowling@localhost:~/dev/ndbconnectors/devel$ ./configure
>>> checking for a BSD-compatible install... /usr/bin/install -c
>>> checking whether build environment is sane... yes
>>> checking for gawk... gawk
>>> checking whether make sets $(MAKE)... yes
>>> ./configure: line 2571: syntax error near unexpected token `1.3.31'
>>> ./configure: line 2571: `  AC_PROG_SWIG(1.3.31)'
>>> jdowling@localhost:~/dev/ndbconnectors/devel$

configure fails with AC_PROG_SWIGJim Dowling19 Oct
  • Re: configure fails with AC_PROG_SWIGMonty Taylor21 Oct
    • Re: configure fails with AC_PROG_SWIGJim Dowling22 Oct
      • Re: configure fails with AC_PROG_SWIGMonty Taylor22 Oct
  • Re: configure fails with AC_PROG_SWIGJim Dowling22 Oct