List:General Discussion« Previous MessageNext Message »
From:Gerald Clark Date:July 9 2001 3:42pm
Subject:Re: LINUX Errors...
View as plain text  
Thats a REALLY old version.


Jon Brookes wrote:

> Hi,
> 
> I have been using mysql fine on a win32 box.. but have now also installed it on Linux
> box.  The version details are below:
> 
> Red Hat Linux release 6.0 (Hedwig)
> Kernel 2.2.5-15smp
> 
> I am using this version of mySQL:
> 
> mysqladmin  Ver 5.3 Distrib 3.20.32a, for pc-linux-gnu on i686
> TCX Datakonsult AB, by Monty
> 
> Server version          3.20.32a
> Protocol version        9
> Connection              Localhost via UNIX socket
> TCP port                3306
> UNIX socket             /var/lib/mysql/mysql.sock
> Uptime:                 17 hours 9 min 15 sec   
> 
> I can log in as root no problem but some of the functions dont seem to be working.
> Check the following example:
> 
> mysql> use mysql;
> ERROR: parse error near 'use mysql' at line 1  
> 
> Although if I login selecting the mySQL database and enter a SELECT statement it
> seems to work without any problems..
> 
> mysql> select * from user;
> 2 rows in set (0.02 sec)
> 
> +-----------+------+----------+-------------+-------------+-------------+-------
> ------+-------------+-----------+-------------+---------------+--------------+--
> ---------+
> | Host      | User | Password | Select_priv | Insert_priv | Update_priv | Delete
> _priv | Create_priv | Drop_priv | Reload_priv | Shutdown_priv | Process_priv | F
> ile_priv |
> +-----------+------+----------+-------------+-------------+-------------+-------
> ------+-------------+-----------+-------------+---------------+--------------+--
> ---------+
> | localhost | root |          | Y           | Y           | Y           | Y
>       | Y           | Y         | Y           | Y             | Y            | Y
>          |
> | localhost |      |          | N           | N           | N           | N
>       | N           | N         | N           | N             | N            | N
>          |
> +-----------+------+----------+-------------+-------------+-------------+-------
> ------+-------------+-----------+-------------+---------------+--------------+--
> ---------+      
> 
> Or if I try to create a new DB from the monitor I get this error:
> 
> mysql> create database testdb;
> ERROR: parse error near 'database testdb' at line 1   
> 
> But when I carry out the same task using mysqladmin it works fine:
> 
> [root@monty mysql]# mysqladmin create testdb
> Database "testdb" created.    
> 
> 
> I am assuming that the server is configured incorrectly in some way..
> 
> Any ideas would be greatly appreciated. Thanks, Jon.


-- 
Gerald L. Clark
gerald_clark@stripped

Thread
LINUX Errors...Jon Brookes4 Jul
  • Re: LINUX Errors...Gerald Clark9 Jul