List:General Discussion« Previous MessageNext Message »
From:Michael Widenius Date:June 30 1999 12:28pm
Subject:Installing over a previous installation in RH 5.2/RPM - conflicts
View as plain text  
>>>>> "Martin" == Martin Edelius <martin.edelius@stripped> writes:

Martin> Hi all.
Martin> I've been searching through all the archives for an answer to this
Martin> questions but have so far not come up with anything useful. So I might
Martin> be asking the same question that has been asked before...

Martin> I am currently using 3.22.14b-gamma and I want to upgrade to 3.22.23b. I
Martin> am running on RH 5.2 so I got the RPM's for this. When checking for
Martin> conflicts I get a whole bunch of them though. A lot of them are language
Martin> related but there are some that I'm a bit worried about, for instance:
Martin> /usr/bin/isamchk conflicts with file from MySQL-3.22.14b-gamma-1
Martin> /usr/bin/isamlog conflicts with file from MySQL-3.22.14b-gamma-1
Martin> /usr/bin/mysql_fix_privilege_tables conflicts with file from
Martin> MySQL-3.22.14b-gamma-1
Martin> /usr/bin/mysql_install_db conflicts with file from
Martin> MySQL-3.22.14b-gamma-1
Martin> /usr/bin/mysql_setpermission conflicts with file from
Martin> MySQL-3.22.14b-gamma-1
Martin> /usr/bin/mysqlbug conflicts with file from MySQL-3.22.14b-gamma-1
Martin> /usr/bin/resolveip conflicts with file from MySQL-3.22.14b-gamma-1
Martin> /usr/bin/safe_mysqld conflicts with file from MySQL-3.22.14b-gamma-1
Martin> /usr/sbin/mysqld conflicts with file from MySQL-3.22.14b-gamma-1

Martin> I was wondering if it's ok to force an upgrade or do I need to uninstall
Martin> the old version?

Hi!

I think that an uninstall + a new install should be safest thing to do.

In any case, take a backup of your database directory first.

Regards,
Monty
Thread
Installing over a previous installation in RH 5.2/RPM - conflictsMartin Edelius30 Jun
  • insert into tableMike Almogy30 Jun
  • Installing over a previous installation in RH 5.2/RPM - conflictsMichael Widenius30 Jun