List:General Discussion« Previous MessageNext Message »
From:Greg Cope Date:January 19 2001 12:48pm
Subject:Re: MySQL 3.23.31 configure fails with Berkeley DB 3.2.3h
View as plain text  
Thimble Smith wrote:
> 
> > >Description:
> >       I just downloaded MySQL 3.23.31 and the "patched version" of
> >       Berkeley DB 3.2.3h from the www.mysql.com site.  I ran configure
> >       with the option to enable the Berkeley DB, but it fails, telling
> >       me I don't have the proper version of the DB.  Here are the last
> >       few lines from the configure output:
> >
> >       checking for BerkeleyDB... supplied
> >       configure: error: didn't find valid BerkeleyDB:
> '/usr/local/BerkeleyDB.3.2' doesn't look like a BDB directory (invalid version 3.2.3 (must
> be at least version 3.2.3g))
> 
> Yes, this configure bug slipped through due to an international
> conspiracy.  But the resistance is still powerful, as evidenced
> by this patch:
> 
> --- acinclude.m4        Thu Jan 18 22:26:20 2001                                +++
> /tmp/acinclude.m4   Fri Jan 19 13:58:24 2001
> @@ -823,12 +823,12 @@
>      bdb_version_ok=yes
>    # This is ugly, but about as good as it can get
>    elif test $db_major -eq 3 && test $db_minor -eq 2 && test
> $db_patch -eq 3 &&\
> -       grep 'DB_VERSION_STRING.*g: ' [$1] > /dev/null
> +       grep 'DB_VERSION_STRING.*h: ' [$1] > /dev/null
>    then
>      bdb_version_ok=yes
>    else
>      bdb_version_ok="invalid version $db_major.$db_minor.$db_patch"
> -    bdb_version_ok="$bdb_version_ok (must be at least version 3.2.3g)"
> +    bdb_version_ok="$bdb_version_ok (must be least version 3.2.3h)"
>    fi
>  ])
> 

Thanks for that.

But does the conspiricy not continue ?  

Do you not need to patch aclocal.m4 as this contains a referance to
3.2.3g, and do the 

replace 'DB_VERSION_STRING.*g' 'DB_VERSION_STRING.*h' -- configure

that Monty suggest to fix the congfigure script ?

Greg

> 
> Sorry about that.
> 
> Tim
> 
> --
>    __  ___     ___ ____  __
>   /  |/  /_ __/ __/ __ \/ /    Tim Smith <tim@stripped>
>  / /|_/ / // /\ \/ /_/ / /__   MySQL AB, Development Team
> /_/  /_/\_, /___/\___\_\___/   Helsinki, Finland (for a few weeks)
>        <___/   www.mysql.com
> 
> ---------------------------------------------------------------------
> Before posting, please check:
>    http://www.mysql.com/manual.php   (the manual)
>    http://lists.mysql.com/           (the list archive)
> 
> To request this thread, e-mail <mysql-thread62368@stripped>
> To unsubscribe, e-mail
> <mysql-unsubscribe-gjjc=rubberplant.freeserve.co.uk@stripped>
> Trouble unsubscribing? Try: http://lists.mysql.com/php/unsubscribe.php
Thread
user database questionMagnus Stenman22 Mar
  • Re: MySQL 3.23.31 configure fails with Berkeley DB 3.2.3hThimble Smith19 Jan
  • Re: MySQL 3.23.31 configure fails with Berkeley DB 3.2.3hGreg Cope19 Jan
Re: user database questionEd Carp22 Mar
  • Re: user database questionMichael Widenius23 Mar
RE: MySQL 3.23.31 configure fails with Berkeley DB 3.2.3hIrena Ivanisevic19 Jan
  • RE: MySQL 3.23.31 configure fails with Berkeley DB 3.2.3hSinisa Milivojevic19 Jan