List:General Discussion« Previous MessageNext Message »
From:Gerald Clark Date:July 26 2000 3:13pm
Subject:Re: Didn't find any fields in table 'forums'
View as plain text  
Mark D Wolinski wrote:

> I'm getting an error on one of my tables when I start mysql:
>
> Didn't find any fields in table 'forums'
>
> doing a: Repair table forums
>
> results in:
>
> +------------------+--------+----------+------------------------------------
> -------------------+
> | Table            | Op     | Msg_type | Msg_text
> |
> +------------------+--------+----------+------------------------------------
> -------------------+
> | master.forums    | repair | error    | Can't find file:
> './cf_master/forums.frm' (errno: 13) |
> +------------------+--------+----------+------------------------------------
> -------------------+
>
> In looking in the directory, the file is there and it's the same size as the
> backup file I made the previous day.
>
> I tried running myisamchk on the MYI file and that was successful, but it
> obviously doesn't affect the frm file.
>
> Any suggestions would greatly be appreciated.
>
> Mark W
>
> --

Check the permissions ont the files in the database, and database directory.
The mysql user probably has no read or write permission.

Make sure the data directory, and all its children are owned by the user specified int the
my.cnf file,
and that user has rwx permissions on them.

Thread
Didn't find any fields in table 'forums'Mark D Wolinski26 Jul
  • RE: Didn't find any fields in table 'forums'Craig Vincent26 Jul
  • Re: Didn't find any fields in table 'forums'Gerald Clark26 Jul
    • RE: Didn't find any fields in table 'forums'Mark D Wolinski26 Jul
  • Re: Didn't find any fields in table 'forums'sinisa26 Jul
  • BDB Table usageJason McKnight26 Jul