List:General Discussion« Previous MessageNext Message »
From:bchill Date:March 11 1999 8:05pm
Subject: configure script fails
View as plain text  
>Description:
	./configure generates this error:

checking if conversion of longlong to float works... no
configure: error: Your compiler can't convert a longlong value to a float!
If you are using gcc 2.8.# you should upgrade to egcs 1.0.3 or newer and try
again

>How-To-Repeat:
	simply run configure (SunOS 5.6 with gcc 2.8.1)
>Fix:
	no clue

>Submitter-Id:	<submitter ID>
>Originator:	Software Manager
>Organization: BCH Technical Services
>MySQL support: none
>Synopsis:	configure script fails
>Severity:	serious
>Priority:	medium
>Category:	mysql
>Class:		sw-bug
>Release:	mysql-3.22.19a (Source distribution)

>Environment:
	
System: SunOS platypus.looksmart.com 5.6 Generic_105181-11 sun4u sparc SUNW,Ultra-2
Architecture: sun4

Some paths:  /usr/bin/perl /pkg/gnu/bin/make /pkg/gnu/bin/gmake /pkg/gnu/bin/gcc
/usr/local/bin/cc
GCC: Reading specs from /pkg/gnu/lib/gcc-lib/sparc-sun-solaris2.6/2.8.1/specs
gcc version 2.8.1
Compilation info: CC='gcc'  CFLAGS=''  CXX='gcc'  CXXFLAGS=''  LDFLAGS=''
Configure command: ./configure  --with-unix-socket-path=/var/tmp/mysql.sock
--with-low-memory --with-mit-threads=yes
Perl: This is perl, version 5.004_04 built for sun4-solaris
Thread
configure script failsbchill11 Mar