List:General Discussion« Previous MessageNext Message »
From:Larry Martell Date:April 18 2013 5:07pm
Subject:Re: logging in using host alias not working
View as plain text  
Found the problem. There was cached DNS info on the host. Restarted
nscd and then it worked.

On Thu, Apr 18, 2013 at 10:59 AM, Larry Martell <larry.martell@stripped> wrote:
> We use host aliases to connect to MySQL all the time, never had an
> issue before. Today we added a new alias, and we cannot connect to the
> server using that one alias but only when we are on the local machine.
>
> Here is the NIS entry for this host:
>
> # ypmatch -k ubshp2 hosts
> ubshp2 192.132.2.143    ubshp2.predict.com ubshp2 ti-us-dev
> intradb-au-qa intradb-us-alpha intradb-us-dev ti-test-dr
> intradb-test-dr
>
> I can connect from all these aliases, except intradb-test-dr when I am
> on ubshp2, e.g.:
>
> From ubshp2 using the intradb-us-dev alias, works:
>
> ti-test-dr@ubshp2: mysql -h intradb-us-dev -u tradeinfra -pXXXX intradb_test_dr
> Welcome to the MySQL monitor.  Commands end with ; or \g.
>
> From ubshp2 using the intradb-au-qa alias, works:
>
> ti-test-dr@ubshp2: mysql -h intradb-au-qa  -u tradeinfra -pXXXX intradb_test_dr
> Welcome to the MySQL monitor.  Commands end with ; or \g.
>
> From ubshp2 using the intradb-test-dr alias, does not work:
>
> ti-test-dr@ubshp2: mysql -h intradb-test-dr -u tradeinfra -pXXXX intradb_test_dr
> ERROR 1045 (28000): Access denied for user
> 'tradeinfra'@'ubshp2.predict.com' (using password: YES)
>
> But from a different host using the intradb-test-dr alias, works:
>
> ti-test-dr@hades: mysql -h intradb-test-dr -u tradeinfra -pXXXX intradb_test_dr
> Welcome to the MySQL monitor.  Commands end with ; or \g.
>
> Anyone have any ideas as to why this one is not working? I've been
> messing with this for 2 days. Nothing in the error log. I've dropped
> and re-added the user, I've bounced the server, I've removed and
> re-added the alias. I've googled and googled and found nothing.
Thread
logging in using host alias not workingLarry Martell18 Apr
  • Re: logging in using host alias not workingLarry Martell18 Apr