List:General Discussion« Previous MessageNext Message »
From:walter harms Date:April 5 2013 7:10am
Subject:Re: MySQL on RHEL4
View as plain text  

Am 05.04.2013 07:56, schrieb Keith Keller:
> On 2013-04-05, Nitin Mehta <ntnmht@stripped> wrote:
>>
>> We're trying to upgrade our existing MySQL 5.1.26 to MySQL 5.1.68 but the
> installation gives error:libc.so.6(GLIBC_2.4) is needed by
> MySQL-server-community-5.1.68-1.rhel5.i386 rtld(GNU_HASH) is needed by
> MySQL-server-community-5.1.68-1.rhel5.i386 Now, GLIBS2.4 is not available for RHEL4 and
> MySQL 5.1 and 5.5 are supported on RHEL4 as per this:
>>  http://www.mysql.com/support/supportedplatforms/database.html
>> Any ideas?
> 
> You have apparently taken an RPM for RHEL5 and attempted to use it in
> RHEL4.  It should not be a surprise that it doesn't work.
> 
> To get it working, either use the correct RPMs (which may not be
> available), compile from source yourself, or upgrade to RHEL5.
> 
> --keith

footnote:
you can also recreate the rpm when you recompile.

re,
 wh
Thread
MySQL on RHEL4Nitin Mehta5 Apr
  • Re: MySQL on RHEL4Keith Keller5 Apr
    • Re: MySQL on RHEL4walter harms5 Apr
    • Re: MySQL on RHEL4Nitin Mehta5 Apr
      • Re: MySQL on RHEL4Reindl Harald5 Apr
  • Re: MySQL on RHEL4Keith Keller6 Apr
    • RE: MySQL on RHEL4Rick James9 Apr