List:General Discussion« Previous MessageNext Message »
From:Mike Franon Date:February 21 2013 6:11pm
Subject:Re: replication fails after upgrade to 5.6
View as plain text  
Unfortunately that is not possible at the moment, I have 6 slaves off
the one master, also I want to test it as much as possible before
upgrading the master.

Is the only way to really fix this is to upgrade master?  I thought
you can replicate from master -> slave if version is higher on slave,
just not the other way around?

Thanks

On Thu, Feb 21, 2013 at 1:03 PM, Reindl Harald <h.reindl@stripped> wrote:
> update the master ASAP in a short timeframe too
> and re-init replication if needed
>
> normally both should have exactly the same version
>
> the slaves must be updated first because otherwise
> a master may write instructions in the binlog the older
> slave does not undersatdn at all, but as said normally
> both should have the same version
>
> Am 21.02.2013 18:03, schrieb Mike Franon:
>> So I created a new test box on AWS, and just did one upgrade from
>> 5.0.96 to 5.1, like I did before and replication will not work from a
>> master with 5.0.96 to a slave with 5.1.68
>>
>> I keep getting Error 1062, Duplicate Entry for key
>>
>> I get no errors when I do a mysql_upgrade, all comes back ok.
>>
>> I was curious if anyone had any ideas?
>>
>> Thanks
>>
>> On Wed, Feb 20, 2013 at 5:51 PM, Mike Franon <kongfranon@stripped> wrote:
>>> This is on a slave, i only upgraded on one box which is the slave i
>>> have not touched master
>>>
>>> On Wed, Feb 20, 2013 at 5:41 PM, Reindl Harald <h.reindl@stripped>
> wrote:
>>>>
>>>>
>>>> Am 20.02.2013 23:27, schrieb Mike Franon:
>>>>> So I successfully upgraded a test db server from 5.0.96 all the way
> up to 5.6
>>>>>
>>>>> Replication as the slave, where the master is 5.0.96, started
> working
>>>>> for about 10 minutes and then got the following error:
>>>>>
>>>>> [ERROR] Slave SQL: Error 'Duplicate entry 'data' for key 'PRIMARY''
> on
>>>>> query. Default database: 'test'. Query: 'UPDATE IGNORE , Error_code:
>>>>> 1062
>>>>>
>>>>> All of our other slaves on 5.0.96 are fine, so I know it has to do
>>>>> with 5.6 but just not sure what, when ir an mysql_upgrade everything
>>>>> was OK
>>>>
>>>> did you surely upgrade and restart the slaves first?
>>>>
>>>> i personally would NOT go to 5.6 now
>>>>
>>>> it is a very young release and looking and the typical changelogs
>>>> replication has always the most fixed bugs
>
Thread
replication fails after upgrade to 5.6Mike Franon20 Feb
  • Re: replication fails after upgrade to 5.6Reindl Harald20 Feb
    • Re: replication fails after upgrade to 5.6Mike Franon20 Feb
      • Re: replication fails after upgrade to 5.6Mike Franon21 Feb
        • Re: replication fails after upgrade to 5.6Reindl Harald21 Feb
          • Re: replication fails after upgrade to 5.6Mike Franon21 Feb
            • Re: replication fails after upgrade to 5.6Reindl Harald21 Feb
              • RE: replication fails after upgrade to 5.6Rick James21 Feb
                • Re: replication fails after upgrade to 5.6Reindl Harald21 Feb
Re: replication fails after upgrade to 5.6Mike Franon22 Feb