List:General Discussion« Previous MessageNext Message »
From:Reindl Harald Date:February 20 2013 10:41pm
Subject:Re: replication fails after upgrade to 5.6
View as plain text  

Am 20.02.2013 23:27, schrieb Mike Franon:
> So I successfully upgraded a test db server from 5.0.96 all the way up to 5.6
> 
> Replication as the slave, where the master is 5.0.96, started working
> for about 10 minutes and then got the following error:
> 
> [ERROR] Slave SQL: Error 'Duplicate entry 'data' for key 'PRIMARY'' on
> query. Default database: 'test'. Query: 'UPDATE IGNORE , Error_code:
> 1062
> 
> All of our other slaves on 5.0.96 are fine, so I know it has to do
> with 5.6 but just not sure what, when ir an mysql_upgrade everything
> was OK

did you surely upgrade and restart the slaves first?

i personally would NOT go to 5.6 now

it is a very young release and looking and the typical changelogs
replication has always the most fixed bugs


Attachment: [application/pgp-signature] OpenPGP digital signature signature.asc
Thread
replication fails after upgrade to 5.6Mike Franon20 Feb
  • Re: replication fails after upgrade to 5.6Reindl Harald20 Feb
    • Re: replication fails after upgrade to 5.6Mike Franon20 Feb
      • Re: replication fails after upgrade to 5.6Mike Franon21 Feb
        • Re: replication fails after upgrade to 5.6Reindl Harald21 Feb
          • Re: replication fails after upgrade to 5.6Mike Franon21 Feb
            • Re: replication fails after upgrade to 5.6Reindl Harald21 Feb
              • RE: replication fails after upgrade to 5.6Rick James21 Feb
                • Re: replication fails after upgrade to 5.6Reindl Harald21 Feb
Re: replication fails after upgrade to 5.6Mike Franon22 Feb