List:General Discussion« Previous MessageNext Message »
From:Mike Franon Date:February 20 2013 7:29pm
Subject:Re: Upgrading form mysql 5.0.90 to 5.5 or 5.6
View as plain text  
OK I got it to work.

I dumped the tables that it was complaining about first, and then
dumped the triggers.

I then uninstalled anything to do with mysql, and installed 5.1

Then imported the tables and triggers, and and able to run
mysql_upgrade without any errors.

This is all without using a full mysqldump.

I am now going to go from 5.1 to 5.5



On Wed, Feb 20, 2013 at 12:54 PM, Mike Franon <kongfranon@stripped> wrote:
> I am pretty sure I did, and when I did I got the following errors:
>
>
> Error: Table Upgrade Required, Please dump/reload to fix it
>
>
> I got that on 10 tables, and also got the following:
>
> Warning:  Triggers for table ' have no creation context.
>
> I think it has to do with no triggers.
>
>
> I know hen I ran the mysql_upgrade it tired to auto repair but did not
> work and failed.
>
> But I will give it a shot again, maybe I missed something.  The other
> thing I was thinking was maybe I can just mysqldump those 10 tables
> that it fails on, and just restore those instead of my entire db.
>
>
> On Wed, Feb 20, 2013 at 12:43 PM, Reindl Harald <h.reindl@stripped>
> wrote:
>>
>>
>> Am 20.02.2013 18:26, schrieb Mike Franon:
>>> So I did a full mysqldump over the weekend for a second time and this
>>> time it is 220GB, no clue what happened last time, I should have
>>> realized looking at the file size something was wrong, but since I got
>>> no errors did not think about it, and this time I timed it, took 7
>>> hours to do a complete mysqldump
>>>
>>> Restoring it is not fun 18+ hours and counting, at this rate it will
>>> be a week, there has to be a better way of doing this, and this is
>>> only going form 5.0 to 5.1
>>>
>>> I know some are saying don't need to do a mysqldump, but if i don't do
>>> it, the upgrade errors out on 10 tables, and then gives me errors
>>> about triggers
>>
>> and did you ALWAYS "mysql_upgarde -root -p" after ANY mysql-update?
>> at least before try a major upgrade?
>>
>> did you try "mysqlcheck -h localhost --check-upgrade --all-databases
> --auto-repair --user=root -p"
>> BEFORE the upgrade? did you try it ALSo after the upgrade?
>>
>> sorry, i do not believe that dump/import is needed and idoubt
>> it will not give better results
>>
Thread
Upgrading form mysql 5.0.90 to 5.5 or 5.6Mike Franon14 Feb
  • Re: Upgrading form mysql 5.0.90 to 5.5 or 5.6Akshay Suryavanshi14 Feb
    • Re: Upgrading form mysql 5.0.90 to 5.5 or 5.6Mike Franon14 Feb
      • Re: Upgrading form mysql 5.0.90 to 5.5 or 5.6Manuel Arostegui14 Feb
      • Re: Upgrading form mysql 5.0.90 to 5.5 or 5.6Mihail Manolov14 Feb
        • RE: Upgrading form mysql 5.0.90 to 5.5 or 5.6Rick James14 Feb
        • Re: Upgrading form mysql 5.0.90 to 5.5 or 5.6Singer Wang14 Feb
          • RE: Upgrading form mysql 5.0.90 to 5.5 or 5.6Rick James14 Feb
            • Re: Upgrading form mysql 5.0.90 to 5.5 or 5.6Mihail Manolov14 Feb
              • RE: Upgrading form mysql 5.0.90 to 5.5 or 5.6Rick James14 Feb
            • Re: Upgrading form mysql 5.0.90 to 5.5 or 5.6Singer Wang14 Feb
              • RE: Upgrading form mysql 5.0.90 to 5.5 or 5.6Rick James15 Feb
                • Re: Upgrading form mysql 5.0.90 to 5.5 or 5.6Mike Franon15 Feb
                  • Re: Upgrading form mysql 5.0.90 to 5.5 or 5.6Keith Murphy15 Feb
                    • Re: Upgrading form mysql 5.0.90 to 5.5 or 5.6Mike Franon15 Feb
                      • Re: Upgrading form mysql 5.0.90 to 5.5 or 5.6Keith Murphy15 Feb
                        • Re: Upgrading form mysql 5.0.90 to 5.5 or 5.6Mike Franon15 Feb
                          • Re: Upgrading form mysql 5.0.90 to 5.5 or 5.6Reindl Harald15 Feb
                            • Re: Upgrading form mysql 5.0.90 to 5.5 or 5.6Johnny Withers15 Feb
                              • Re: Upgrading form mysql 5.0.90 to 5.5 or 5.6Reindl Harald15 Feb
                            • Re: Upgrading form mysql 5.0.90 to 5.5 or 5.6Akshay Suryavanshi15 Feb
                              • Re: Upgrading form mysql 5.0.90 to 5.5 or 5.6Reindl Harald15 Feb
                            • Re: Upgrading form mysql 5.0.90 to 5.5 or 5.6Manuel Arostegui16 Feb
                              • Re: Upgrading form mysql 5.0.90 to 5.5 or 5.6Reindl Harald16 Feb
                                • Re: Upgrading form mysql 5.0.90 to 5.5 or 5.6Divesh Kamra19 Feb
                                  • Re: Upgrading form mysql 5.0.90 to 5.5 or 5.6Reindl Harald19 Feb
                                    • Re: Upgrading form mysql 5.0.90 to 5.5 or 5.6Divesh Kamra19 Feb
                                      • Re: Upgrading form mysql 5.0.90 to 5.5 or 5.6Reindl Harald19 Feb
                                        • Re: Upgrading form mysql 5.0.90 to 5.5 or 5.6Mike Franon20 Feb
                                          • Re: Upgrading form mysql 5.0.90 to 5.5 or 5.6Reindl Harald20 Feb
                                            • Re: Upgrading form mysql 5.0.90 to 5.5 or 5.6Mike Franon20 Feb
                                              • Re: Upgrading form mysql 5.0.90 to 5.5 or 5.6Mike Franon20 Feb
                                                • Re: Upgrading form mysql 5.0.90 to 5.5 or 5.6Reindl Harald20 Feb
                                                  • Re: Upgrading form mysql 5.0.90 to 5.5 or 5.6Mike Franon20 Feb
                                    • Re: Upgrading form mysql 5.0.90 to 5.5 or 5.6Sabika Makhdoom19 Feb
                      • Re: Upgrading form mysql 5.0.90 to 5.5 or 5.6Reindl Harald15 Feb