List:General Discussion« Previous MessageNext Message »
From:Johnny Withers Date:August 17 2011 1:42pm
Subject:Re: Concerned : Developer getting There is no 'root'@'%' registered
error message
View as plain text  
Change the definer to one of your registered root accounts. Root@127 or
root@localhost.

On Aug 17, 2011 8:39 AM, "Brent Clark" <brentgclarklist@stripped> wrote:

Hiya

Ill be up front my saying my knowledge of store procedures is limited.

A Developer gave me a procedure to load.

It starts off with:

CREATE DEFINER=`root`@`%` PROCEDURE ....


But now, the developer informs me that he gets the following message. There
is no 'root'@'%' registered

Googling reveals the following link : http://forums.mysql.com/read.**
php?10,237843,238950#msg-**238950<http://forums.mysql.com/read.php?10,237843,238950#msg-238950>

And that I can run:

GRANT ALL PRIVILEGES ON *.* TO 'root'@'%' IDENTIFIED BY 'mysql' WITH GRANT
OPTION;

Im hesitant to do it.

My Mysql root acess details are:

mysql> select user, host from user WHERE user = 'root';
+------+-------------+
| user | host        |
+------+-------------+
| root | 127.0.0.1   |
| root | localhost   |
+------+-------------+

If someone can share their opinion, thoughts or share the same concerns it
would be appreciated.

Kind Regards
Brent Clark

Thread
Concerned : Developer getting There is no 'root'@'%' registered errormessageBrent Clark17 Aug
Re: Concerned : Developer getting There is no 'root'@'%' registerederror messageJohnny Withers17 Aug
  • Re: Concerned : Developer getting There is no 'root'@'%' registerederror messageBrent Clark17 Aug
    • Re: Concerned : Developer getting There is no 'root'@'%' registered error messageJohan De Meersman17 Aug
      • RE: Concerned : Developer getting There is no 'root'@'%' registered error messageDavid Lerer17 Aug
        • Re: Concerned : Developer getting There is no 'root'@'%' registered error messageJohan De Meersman18 Aug
          • RE: Concerned : Developer getting There is no 'root'@'%' registered error messageDavid Lerer18 Aug
            • Re: Concerned : Developer getting There is no 'root'@'%' registered error messageJohan De Meersman18 Aug
Re: Concerned : Developer getting There is no 'root'@'%' registerederror messageJohnny Withers17 Aug
  • Re: Concerned : Developer getting There is no 'root'@'%' registerederror messageJon Siebert17 Aug