List:General Discussion« Previous MessageNext Message »
From:Joerg Bruehe Date:January 31 2011 6:31pm
Subject:Re: libmysqlclient.so.16 no version information available
View as plain text  
Harald,


Reindl Harald wrote:
> You need mysql-5.1 compat-libs package
> or rebuild applications against 5.5

Your advice is correct in general, but not in this case:
1) Noel builds from source, as he writes later.
2) Both MySQL 5.1 and 5.5 come with version 16 of "libmysqlclient", so
   an application built against MySQL 5.1 can directly use that of 5.5.

> 
> [[...]]
> 
> this is nothing new and was the same with 5.1
> while applications was linked against 5.0

Right, MySQL 5.0 -> 5.1 had the transition 15 -> 16 for
"libmysqlclient[_r].so".


Regards,
Jörg

-- 
Joerg Bruehe,  MySQL Build Team,  joerg.bruehe@stripped
ORACLE Deutschland B.V. & Co. KG,   Komturstrasse 18a,   D-12099 Berlin
Geschaeftsfuehrer: Juergen Kunz, Marcel v.d. Molen, Alexander v.d. Ven
Amtsgericht Muenchen: HRA 95603

Thread
libmysqlclient.so.16 no version information availableNoel Butler31 Jan
  • Re: libmysqlclient.so.16 no version information availableReindl Harald31 Jan
    • Re: libmysqlclient.so.16 no version information availableNoel Butler31 Jan
      • Re: libmysqlclient.so.16 no version information availableReindl Harald31 Jan
        • Re: libmysqlclient.so.16 no version information availableNoel Butler31 Jan
    • Re: libmysqlclient.so.16 no version information availableJoerg Bruehe31 Jan
      • Re: libmysqlclient.so.16 no version information availableReindl Harald31 Jan
  • Re: libmysqlclient.so.16 no version information availableJoerg Bruehe31 Jan