On Mon, 2011-01-31 at 11:42 +0100, Reindl Harald wrote:
Have you rebuilt all depending applications AFTER
rebuild of mysql 5.5?


yes, built 5.5 a month ago, only today rebuilt postfix (upgraded 2.7.2 to 2.8.0)
This is a common problem, google fu indicates others have same problem, some of them claim reverting to 5.5.7 corrects this error, there was major changes from 5.5.7 to 5.5.8, but I don't see the sense in downgrading to what was regarded as unstable mysql version to correct it. just as well this is on a dev testbed and not production, more of a reason production will stay on 5.1 I think.



BTW:
I also make my own source-builds with optimized flags but not dumb
configure & make, the better way is to build clean distro-packages
and install them with the package-manager, this way you would

I totally disagree. but thats the beauty about open source, each to their own.


when there is only one version of the lib installed it should not be an issue, I've been building tarballs for 20 years, so do understand  how the OS works and how to best use configure :)


Am 31.01.2011 11:38, schrieb Noel Butler:
> On Mon, 2011-01-31 at 10:52 +0100, Reindl Harald wrote:
>> You need mysql-5.1 compat-libs package
>> or rebuild applications against 5.5
>>
>> for feddora/rhel type "compat-mysql51" in google
>> there are packages from remi since he builds 5.5
>>
>> this is nothing new and was the same with 5.1
>> while applications was linked against 5.0
>>
> 
> HUH? These are all source builds,  I did not have this problem previously, I don't use package maintainers versions.
> I have source builds of mysql, postfix, dovecot, apache, php, bind - pretty much all the common main daemons, i
> don't trust distro butchers , err, i mean maintainers, for these critical apps.
> 
> thanks anyway.

>> Am 31.01.2011 09:24, schrieb Noel Butler:
>> > 
>> > Arg!  This abomination  5.5 is causing more headaches,
>> > 
>> > postfix will not run, I've heard dovecot may not either, amongst others
>> > 
>> > 
>> > postconf: /usr/lib/libmysqlclient.so.16: no version information available (required by postcon
>> > /etc/init.d/postfix start
>> > * Starting Postfix Mail Transport Agent postfix                                               postconf:
>> > /usr/lib/libmysqlclient.so.16: no version information available (required by postconf)
>> > /usr/sbin/postconf: /usr/lib/libmysqlclient.so.16: no version information available (required by /usr/sbin/postconf)
>> > /usr/sbin/postconf: /usr/lib/libmysqlclient.so.16: no version information available (required by /usr/sbin/postconf)
>> >                                                                                         [fail]
>> > *sigh*  Why was this removed, or is this another side affect of that amazing winblozy P.O.S cmake?
>>
>