List:General Discussion« Previous MessageNext Message »
From:Tim Thorburn Date:December 16 2010 8:42am
Subject:Unable to add users with MySQL 5.5.8 under Windows
View as plain text  
Hello,

I just downloaded MySQL 5.5.8 (Win64 version) today and installed it on 
my dev machine.  Previously I had MySQL 5.1.51 installed - as I've 
always felt it was better to uninstall the old before installing the new 
with Windows, I uninstalled 5.1.51 by doing the following:
- As Administrator, I ran DOS prompt and entered NET STOP MYSQL
- Ran MySQL Instance Configuration Wizard to remove the current instance
- Uninstalled MySQL Server 5.1.51 from Control Panel
- Went through my Users, ProgramData, and Program Files folders to 
delete any references to MySQL.
- Reboot computer

I should mention this is Windows 7 Ultimate 64-bit.  After rebooting I 
installed MySQL 5.5.8 for Win64 using the downloaded MSI file.  Once 
MySQL was installed, I downloaded and installed the current version of 
Workbench (5.2.31a).  When I run Workbench, I see that the MySQL server 
is indeed running - I'll also mention that this is my first time using 
Workbench, until now I had been using the older MySQL Administrator GUI, 
however it stopped working with 5.5.8.  So, back in Workbench, I goto 
Manage Security under the Server Administration heading, choosing the 
default Local instance: MySQL server to connect to.  Next I click 
Accounts and finally Add Account at the bottom of this screen.  Under 
Details for Account newuser@% I add in the user name I want, type the 
password twice, I've tried leaving Limit Connectivity to Hosts Matching 
as % and localhost.

Once I'm finished adding the user, I click Apply - however I'm presented 
with the following error message:

/Unhandled exception: Error adding account accountName@%:/

I've tried adding a user in MySQL Administrator, as I am more familiar 
with it.  It provides a different error:

/Error while storing the user information.  The user might have been 
deleted.  Please refersh the user list./

A command prompt pop-up appears with this error stating the following:

/** Message: save user: error adding new user entry

/I've googled the above error messages and found that either bug reports 
with similar wording were either abandoned, or supposed to be fixed 
already.  Any thoughts, or should I go back to 5.1.51 and wait for the 
next point release of the 5.5 line?

TIA,
-Tim

Thread
Autostart not working for me in 5.5.8 versionYangontha Maung16 Dec
  • Re: Autostart not working for me in 5.5.8 versionYangontha Maung16 Dec
    • Re: Autostart not working for me in 5.5.8 versionAlejandro Bednarik16 Dec
      • Re: Autostart not working for me in 5.5.8 versionNoel Butler19 Dec
        • Re: Autostart not working for me in 5.5.8 versionJoerg Bruehe20 Dec
          • Re: Autostart not working for me in 5.5.8 versionNoel Butler21 Dec
  • Unable to add users with MySQL 5.5.8 under WindowsTim Thorburn16 Dec
    • Re: Unable to add users with MySQL 5.5.8 under WindowsTim Thorburn16 Dec
      • Re: Unable to add users with MySQL 5.5.8 under WindowsMySQL)16 Dec