List:General Discussion« Previous MessageNext Message »
From:Joerg Bruehe Date:August 26 2010 3:47pm
Subject:Re: Can't install perl-DBD-MySQL
View as plain text  
Nunzio,


Nunzio Daveri wrote:
> Hello gurus, I am trying to install the perl-DBD-MySQL and each time I get this 
> error message.  Any ideas?  I have tried it on a Sun X4150 (Dual Quad Cored 
> Intel) and a Sun X4200 (Dual Dual Core Opteron) both on CentOS 4.8.  I have 
> tried to install and build with MySQL 4.x on the box and then removed it and 
> installed 5.x but both times I get the same error message :-(
> 
> Anyone have any ideas why it constantly dies and how to fix it please?  I can't 
> even locate what is is complaining about, I think it's v14 of 
> libmysqlclient.so???

Of course.

Perl-DBD-MySQL was built against an older version of MySQL, from the
message you can tell it was MySQL 4.1.22, so you need that version of
the shared client library.
(Strictly speaking, you don't need 4.1.22 specifically, any version that
uses the same ABI will do, which should be any 4.1 version; they all are
version 14 of the library interface.)
(You even have version 10 of the library installed, which is really old
by now.)

With the RPMs built and published by the MySQL team, you will get that
in the "shared-compat" RPM that corresponds to your platform.

Until now, "shared-compat" will conflict with "shared", as it also
contains the current version of the shared client library. So you need
to uninstall "shared" and install "shared-compat".

We intend to change that, probably with the upcoming version 5.5.6:
From then onward, you can (un)install a "shared-compat" RPM without
affecting the "shared" RPM, as then the "shared-compat" will contain
only the previous versions of the client library and not the current one.

If you don't want to install MySQL from RPMs, you can still take a
"shared-compat" RPM and use "rpm2cpio" to extract libmysqlclient.so.14
from it. You could do the same with a 4.1 package, but I think they are
removed from the archive by now as they are really outdated.

An alternative would be to get a newer Perl-DBD-MySQL package that was
built using a more current version of MySQL, or to build that from
source using the current MySQL.


The choice is yours,
Jörg


Original quote left on intention, for those who want to check the message:

> 
> [root]# rpm -i ./perl-DBD-MySQL-2.9004-3.1.centos4.i386.rpm
> error: Failed dependencies:
>         libmysqlclient.so.14 is needed by perl-DBD-MySQL-2.9004-3.1.centos4.i386
>     Suggested resolutions:
>         
> /home/buildcentos/CENTOS/en/4.0/i386/CentOS/RPMS/mysql-4.1.22-2.el4.i386.rpm
> [root]# updatedb
> [root]# locate libmysqlclient.so.14
> [root]# locate libmysqlclient.so
>
> /usr/src/redhat/BUILD/mysql-5.1.44/mysql-debug-5.1.44/libmysql/.libs/libmysqlclient.so.16.0.0
> 
>
> /usr/src/redhat/BUILD/mysql-5.1.44/mysql-debug-5.1.44/libmysql/.libs/libmysqlclient.so
> 
>
> /usr/src/redhat/BUILD/mysql-5.1.44/mysql-debug-5.1.44/libmysql/.libs/libmysqlclient.so.16
> 
> /usr/lib/mysql/libmysqlclient.so.10.0.0
> /usr/lib/mysql/libmysqlclient.so.10
> /home/nunzio/mysql-5.1.44-linux-i686-glibc23/lib/libmysqlclient.so
> /home/nunzio/mysql-5.1.44-linux-i686-glibc23/lib/libmysqlclient.so.16.0.0
> /home/nunzio/mysql-5.1.44-linux-i686-glibc23/lib/libmysqlclient.so.16
> /mysql_5.1/lib/libmysqlclient.so
> /mysql_5.1/lib/libmysqlclient.so.16.0.0
> /mysql_5.1/lib/libmysqlclient.so.16
> 
> 
> 
> 


-- 
Joerg Bruehe,  MySQL Build Team,  joerg.bruehe@stripped
               (+49 30) 417 01 487
ORACLE Deutschland B.V. & Co. KG,   Komturstrasse 18a,   D-12099 Berlin
Geschaeftsfuehrer: Juergen Kunz, Marcel v.d. Molen, Alexander v.d. Ven
Amtsgericht Muenchen: HRA 95603

Thread
Can't install perl-DBD-MySQLNunzio Daveri26 Aug
  • Re: Can't install perl-DBD-MySQLJoerg Bruehe26 Aug