List:General Discussion« Previous MessageNext Message »
From:Mike Spreitzer Date:July 19 2010 6:56pm
Subject:mysql-workbench-gpl-5.2.25-1el6.x86_64.rpm depends on a lot of stuff I do
not have
View as plain text  
Today I downloaded MySQL-server-community, MySQL-client-community, 
MySQL-shared-community, and mysql-workbench-gpl to install on an 
RHEL5/x86_64 machine.  The first three installed just fine.  The fourth 
failed due to a large pile of missing dependencies (see below).  I do not 
even know where to get them all.  Is there some one place that provides 
them all?  Am I missing something obvious here?

# rpm -ivh mysql-workbench-gpl-5.2.25-1el6.x86_64.rpm 
error: Failed dependencies:
        libatkmm-1.6.so.1()(64bit) is needed by 
mysql-workbench-gpl-5.2.25-1el6.x86_64
        libcairomm-1.0.so.1()(64bit) is needed by 
mysql-workbench-gpl-5.2.25-1el6.x86_64
        libcrypto.so.10()(64bit) is needed by 
mysql-workbench-gpl-5.2.25-1el6.x86_64
        libgdkmm-2.4.so.1()(64bit) is needed by 
mysql-workbench-gpl-5.2.25-1el6.x86_64
        libgio-2.0.so.0()(64bit) is needed by 
mysql-workbench-gpl-5.2.25-1el6.x86_64
        libgiomm-2.4.so.1()(64bit) is needed by 
mysql-workbench-gpl-5.2.25-1el6.x86_64
        libglibmm-2.4.so.1()(64bit) is needed by 
mysql-workbench-gpl-5.2.25-1el6.x86_64
        libgtkmm-2.4.so.1()(64bit) is needed by 
mysql-workbench-gpl-5.2.25-1el6.x86_64
        liblua-5.1.so()(64bit) is needed by 
mysql-workbench-gpl-5.2.25-1el6.x86_64
        libpangomm-1.4.so.1()(64bit) is needed by 
mysql-workbench-gpl-5.2.25-1el6.x86_64
        libpython2.6.so.1.0()(64bit) is needed by 
mysql-workbench-gpl-5.2.25-1el6.x86_64
        libsigc-2.0.so.0()(64bit) is needed by 
mysql-workbench-gpl-5.2.25-1el6.x86_64
        libssl.so.10()(64bit) is needed by 
mysql-workbench-gpl-5.2.25-1el6.x86_64
        libstdc++.so.6(GLIBCXX_3.4.10)(64bit) is needed by 
mysql-workbench-gpl-5.2.25-1el6.x86_64
        libstdc++.so.6(GLIBCXX_3.4.11)(64bit) is needed by 
mysql-workbench-gpl-5.2.25-1el6.x86_64
        libstdc++.so.6(GLIBCXX_3.4.9)(64bit) is needed by 
mysql-workbench-gpl-5.2.25-1el6.x86_64
        libuuid.so.1(UUID_1.0)(64bit) is needed by 
mysql-workbench-gpl-5.2.25-1el6.x86_64
        libxml2.so.2(LIBXML2_2.4.30)(64bit) is needed by 
mysql-workbench-gpl-5.2.25-1el6.x86_64
        libxml2.so.2(LIBXML2_2.6.0)(64bit) is needed by 
mysql-workbench-gpl-5.2.25-1el6.x86_64
        libzip.so.1()(64bit) is needed by 
mysql-workbench-gpl-5.2.25-1el6.x86_64
        python-paramiko is needed by 
mysql-workbench-gpl-5.2.25-1el6.x86_64

Thanks,
Mike Spreitzer

Thread
mysql-workbench-gpl-5.2.25-1el6.x86_64.rpm depends on a lot of stuff I donot haveMike Spreitzer19 Jul
  • Re: mysql-workbench-gpl-5.2.25-1el6.x86_64.rpm depends on a lot ofstuff I do not haveJoerg Bruehe20 Jul