List:General Discussion« Previous MessageNext Message »
From:Machiel Richards Date:February 23 2010 7:59am
Subject:slow queries not being logged
View as plain text  
Good day all

 

                I hope you can assist me with this one...

 

                We have a client where the slow query log was disabled.

 

                We noticed that the slow query amount (when viewing global
status) has skyrocketed during the last 2 weeks going up to over 2 million
(from 160 million queries).

 

                We wanted to look at these queries to see if it can be
optimised to reduce the amount and went through the whole database restart
routine to enable the slow query log again (they are running version 5.0 so
had to restart).

 

 

                However, even though the slow query log is enabled, it is
not logging the queries to the file specified.

 

                Can someone please assist in why this is not being done? I
thought that it might be logging to a default filename but there is only one
slow queries log file in the directory and it is empty.

 

                Checking the global status again, it showed 29 000 slow
queries since this morning (3 hours ago) but nothing in the logs.

 

 

                Your help will be appreciated.

 

 

Regards

 


Thread
slow queries not being loggedMachiel Richards23 Feb
  • RE: slow queries not being loggedJohn Daisley23 Feb
    • RE: slow queries not being loggedMachiel Richards23 Feb
      • Re: slow queries not being loggedAnanda Kumar23 Feb
        • Re: slow queries not being loggedCarsten Pedersen23 Feb