List:General Discussion« Previous MessageNext Message »
From:Aarno Syvänen Date:January 6 2010 9:20am
Subject:Re: Help for mysql@lists.mysql.com
View as plain text  
Hi list,

i am trying to add mysql support to my project using autoconf.
Following flags are
are generated:

LIBS=-lmysqlclient -lssl -lpthread -lresolv -lm  -L/usr/lib -lcrypto -
lssl -lstdc++ -L/Developer/SDKs/MacOSX10.4u.sdk/usr/lib  -L/Developer/
SDKs/MacOSX10.4u.sdk/usr/lib/system -L/usr/local/mysql/lib/mysql -
lmysqlclient -lz -lm -L/usr/lib -lxml2 -lz -lpthread  -licucore -lm -
framework Cocoa -framework -framework CoreFoundation -lobjc

CFLAGS=-D_REENTRANT=1 -Wno-pointer-sign -I. -g -O -mmacosx-version-
min=10.5 -isysroot /Developer/SDKs/MacOSX10.5.sdk -DDARWIN=1 -I/usr/
include/openssl -I/usr/local/mysql/include/mysql -fno-omit-frame-
pointer -arch ppc -arch i386 -I/Developer/SDKs/MacOSX10.4u.sdk/usr/
include -I/Developer/SDKs/MacOSX10.4u.sdk/usr/include/libxml2 L/
Developer/SDKs/MacOSX10.4u.sdk/usr/lib -L/Developer/SDKs/
MacOSX10.4u.sdk/usr/lib/system -I/usr/include/libxml2

This does not compile, but if i change manually SDKs to 10.5, it does.

If i disable mysql, i just get:

CFLAGS=-D_REENTRANT=1 -Wno-pointer-sign -I. -g -O -mmacosx-version-
min=10.5 -isysroot /Developer/SDKs/MacOSX10.5.sdk I/usr/include/
openssl -I/usr/include/libxml2

LIBS= -lssl -lpthread -lresolv -lm  -L/usr/lib -lcrypto -lssl -L/usr/
lib -lxml2 -lz -lpthread -licucore -lm -framework Cocoa framework
CoreFoundation -lobjc

So it seams that my mysql version knows only about version 10.4. What
mysql version understands 10.5 ? And if someone has had same
problem, it would be nice to have some feedback.

Aarno

Thread
Re: Help for mysql@lists.mysql.comAarno Syvänen6 Jan