List:General Discussion« Previous MessageNext Message »
From:René Fournier Date:November 20 2009 4:30pm
Subject:Strange problem with mysqldump / automysqlbackup (ERROR 1300)
View as plain text  
I've been using automysqlbackup 2.5 for years on a particular database, and it's always
performed great. Recently, however, I've become encountering problems when trying to
re-import one of its dumped sql files. (Not sure if it matters, but the database file in
question is large and growing -- about 10GB. The other databases automysqlbackup backs up
are fine.)

Basically on the import, MySQL fails and returns an error indicating a problem with the
dump file:

mysql -u root -p < dump_file.sql  (~10GB) 
Enter password: 
ERROR 1300 (HY000) at line 426: Invalid utf8 character string: '?03422'

Sure enough, I look at the line in dump_file.sql, which should contain two unsigned ints,
and two unsigned small ints:

	[...],(32562206,1228?03422,1641,135),[...]

And yup, there's a question mark in the middle of the second unsigned int, for some
strange reason. Not in any of the other rows in that statement. When I look at the
existing database from which the dump file was made, that row is fine:

mysql> SELECT * FROM bandwidth WHERE id = 32562206;
+----------+------------+-----------+-------+
| id       | time_sec   | device_id | bytes |
+----------+------------+-----------+-------+
| 32562206 | 1228803422 |      1641 |   135 |
+----------+------------+-----------+-------+
1 row in set (0.00 sec)


So... It appears either mysqldump and/or automysqlbackup is having a problem dumping a
true copy of the database.

Anyone else run into this sort of thing? Any suggestions? Thanks.

...Rene
Thread
Strange problem with mysqldump / automysqlbackup (ERROR 1300)René Fournier20 Nov
  • RE: Strange problem with mysqldump / automysqlbackup (ERROR 1300)Gavin Towey20 Nov
    • Re: Strange problem with mysqldump / automysqlbackup (ERROR 1300)René Fournier20 Nov
      • Re: Strange problem with mysqldump / automysqlbackup (ERROR 1300)René Fournier23 Nov
Re: Strange problem with mysqldump / automysqlbackup (ERROR 1300)René Fournier21 Nov
  • Re: Strange problem with mysqldump / automysqlbackup (ERROR 1300)Claudio Nanni22 Nov
    • Re: Strange problem with mysqldump / automysqlbackup (ERROR 1300)René Fournier22 Nov